Начальная страница

  • Начальная страница

Агент Плюс: Управление дистрибуцией. Часто задаваемые вопросы.

В данном руководстве собраны наиболее часто задаваемые вопросы по функционалу конфигурации "Агент Плюс: Управление дистрибуцией".


1. Обмен данными между "Агент Плюс: Управление дистрибуцией" и учетной системой

После установки программного продукта "Агент Плюс: Управление дистрибуцией" необходимо заполнить базу данных данными из учетной системы. Для этого необходимо произвести первоначальную выгрузку из учетной системы организации в "Агент Плюс: Управление дистрибуцией".
В конфигурации реализованы механизмы обмена данными с типовыми конфигурациями "1С: Управление торговлей", редакция 10.3, "1С: Управление торговлей", редакция 11.2 и "1С:ERP Управление предприятием 2" при помощи внешних обработок, входящих в комплект поставки конфигурации "Агент Плюс: Управление дистрибуцией".
Настройка обмена данными между конфигурациями происходит непосредственно в окне запущенной обработки.
См. также:
  • •
    Первоначальная выгрузка данных из "1С:Управление торговлей", ред. 11.2 и "1С:ERP Управление предприятием 2"
  • •
    Добавление плана обмена "Полный" для конфигурации "1С:ERP Управление предприятием 2"
  • •
    Первоначальная выгрузка данных из "1С:Управление торговлей", ред. 10.3
  • •
    Обмен данными с "1С:Управление торговлей", редакция 10.3
  • •
    Обмен данными с "1С:Управление торговлей", редакция 11.2
  • •
    Обмен данными с "1С:ERP Управление предприятием 2"
  • •
    Обработка для загрузки/выгрузки данных на стороне "Агент Плюс:Управление дистрибуцией"


Первоначальная выгрузка данных из "1С:Управление торговлей", ред. 11.2 и "1С:ERP Управление предприятием 2"

Для заполнения конфигурации "1С:Управление дистрибуцией" данными из учетной системы "1С:Управление торговлей", редакция 11.2 или "1С:ERP Управление предприятием 2" необходимо произвести процедуру первоначальной выгрузки данных при помощи обработки "Первоначальная выгрузка данных". Перед первоначальной выгрузкой из конфигурации "1С:ERP Управление предприятием 2" необходимо создать план обмена "Полный". Инструкцию см. в разделе "Добавление плана обмена "Полный" для конфигурации "1С:ERP Управление предприятием 2" ".
Для запуска обработки необходимо открыть внешний файл с названием "ПервоначальноеЗаполнение83.epf" для "1С:Управление торговлей", редакция 11.2 или "ПервоначальноеЗаполнение83_ERP.epf" для "1С:ERP Управление предприятием 2".
Заполнение обработки выполняется в пять этапов, для перехода к следующему этапу необходимо нажать на кнопку "Далее>". На каждой закладке задаются необходимые настройки и выполняется выгрузка определенных данных из конфигурации "1С:Управление торговлей", ред.11.2 или "1С:ERP Управление предприятием 2".
Важно.
Если первоначальная выгрузка была проведена за один период, но после этого возникла необходимость выгрузить первоначальные данные за больший период, следует обязательно удалить документы корректировки по остаткам и взаиморасчетам по первоначальной выгрузке, выгруженные ранее.
Настройка каталога и узла для обмена
Первоначальная выгрузка данных из "1С:Управление торговлей", ред. 11.2 и "1С:ERP Управление предприятием 2"
Рис. 1.1. Обработка "Первоначальная выгрузка данных" для УТ 11.2 и ERP 2.0.
Этап "Настройка каталога и узла для обмена"
На этапе "Настройка каталога и узла для обмена" ( Рис. 1.1 ) задаются каталог обмена и узлы плана обмена "Полный".
В поле "Каталог для сохранения файлов первоначальной выгрузки" указывается папка на локальном или сетевом диске, в которую будет выгружен архив с первоначальной информацией.
При первом запуске обработки в списке узлов "План обмена "Полный"" отображаются все текущие созданные узлы обмена плана "Полный". Если ранее для информационной системы не был создан основной узел обмена, то для указания основного узла обмена (текущей информационной базы) необходимо нажать на кнопку "Заполнить основной". По умолчанию для основного узла обмена устанавливаются код "001" и наименование "Основной". После заполнения основного узла обмена кнопка "Заполнить основной" становится недоступной.
Далее необходимо создать узел обмена, на котором будут регистрироваться изменения объектов для решения "Агент Плюс: Управление дистрибуцией". Для этого необходимо нажать на кнопку "Создать подчиненный". В результате чего будет создан узел обмена с наименованием "Управление дистрибуцией" и кодом (префиксом) "УД". В случае если данный префикс занят созданным ранее узлом обмена, то этот узел будет переименован в "Управление дистрибуцией".
Для того, чтобы указать узел, участвующий в обмене необходимо нажать на кнопку "Узел для обмена". Выбранный узел обмена в табличной части выделяется жирным шрифтом.
Для перехода к следующему этапу настройки необходимо нажать на кнопку "Далее>".
Выгрузка нормативно-справочной информации
Рис. 1.2. Обработка "Первоначальная выгрузка данных" для УТ 11.2 и ERP 2.0.
Этап "Выгрузка нормативно-справочной информации"
Обмен данными всегда должен начинаться с первоначальной выгрузки нормативно-справочной информации (НСИ) ( Рис. 1.2 ). Однако, в обработке предусмотрена возможность пропуска данного этапа выгрузки. Для этого необходимо установить флажок "Пропустить шаг" в нижней части окна обработки.
Для запуска выгрузки нормативно-справочной информации необходимо нажать на кнопку "Далее>". В результате в папке, указанном в поле "Каталог для сохранения файлов первоначальной выгрузки", будет сформирован архив обмена с названием "FromUT_first_data.zip".
Регистрация последних цен номенклатуры
Рис. 1.3. Обработка "Первоначальная выгрузка данных" для УТ 11.2 и ERP 2.0.
Этап "Регистрация последних цен номенклатуры"
Следующий этап первоначальной выгрузки данных - выгрузка среза последних цен номенклатуры ( Рис. 1.3 ).
Для выгрузки последних (актуальных) цен номенклатуры необходимо указать дату среза последних цен и нажать на кнопку "Далее>". В результате в каталоге, указанном в поле "Каталог для сохранения файлов первоначальной выгрузки", будет сформирован файл обмена с названием "FromUT_last_prices.zip".
В обработке предусмотрена возможность пропуска данного этапа выгрузки. Для этого необходимо установить флажок "Пропустить шаг" в нижней части окна обработки.
Выгрузка среза последних остатков номенклатуры и взаиморасчетов с клиентами
Рис. 1.4. Обработка "Первоначальная выгрузка данных" для УТ 11.2 и ERP 2.0.
Этап "Выгрузка среза последних остатков номенклатуры и взаиморасчетов с клиентами"
После выгрузки цен номенклатуры необходимо выгрузить актуальные остатки товаров ( Рис. 1.4 ).
Для выгрузки актуальных остатков номенклатуры необходимо указать дату среза остатков и нажать на кнопку "Далее>". В результате в каталоге, указанном в поле "Каталог для сохранения файлов первоначальной выгрузки", будет сформирован файл обмена с названием "FromUT_last_rests.zip".
Важно.
Датой среза принимается дата, ранее которой гарантированно не будут изменяться документы, влияющие на остатки товаров и взаиморасчеты с клиентами.
В обработке предусмотрена возможность пропуска данного этапа выгрузки. Для этого необходимо установить флажок "Пропустить шаг" в нижней части окна обработки.
Выгрузка первоначальных документов оборотов
Рис. 1.5. Обработка "Первоначальная выгрузка данных" для УТ 11.2 и ERP 2.0.
Этап "Выгрузка первоначальных документов оборотов"
Следующий этап обмена - первоначальная выгрузка оборотов продаж (документов "Корректировка остатков товаров") ( Рис. 1.5 ).
Для выгрузки оборотов продаж необходимо в форме обработки указать период, за который будут выгружены документы Корректировка остатков товаров. При нажатии на кнопку "Далее>" в каталоге, указанном в поле "Каталог для сохранения файлов первоначальной выгрузки", будет сформирован файл обмена с названием "FromUT_docs_of_turnovers.zip".
Важно.
Дата начала периода выгрузки документов оборотов и дата среза последних остатков номенклатуры и взаиморасчетов с клиентами должны совпадать.
В обработке предусмотрена возможность пропуска данного этапа выгрузки. Для этого необходимо установить флажок "Пропустить шаг" в нижней части окна обработки.
Архивы с выгруженными данными необходимо загрузить в конфигурацию "Управление дистрибуцией". Для загрузки данных необходимо открыть внешнюю обработку "ExchangeAdapterUD", входящую в состав комплекта поставки.
См. также:
  • •
    Добавление плана обмена "Полный" для конфигурации "1С:ERP Управление предприятием 2"


Добавление плана обмена "Полный" для конфигурации "1С:ERP Управление предприятием 2"

Перед проведением первоначальной выгрузки из "1С:ERP Управление предприятием 2" необходимо создать план обмена "Полный". Для этого необходимо Для этого в режиме "Конфигуратор" необходимо включить возможность изменения вашей текущей конфигурации, стоящей на поддержке, выбрав пункт меню "Конфигурация – Поддержка – Настройка поддержки". В результате на экране появится следующее окно ( Рис. 1.6 ).
Добавление плана обмена "Полный" для конфигурации "1С:ERP Управление предприятием 2"
1.6. Окно "Настройка поддержки"
В диалоговом окне необходимо нажать на кнопку "Включить возможность изменения" и установить правила поддержки "Объект поставщика редактируется с сохранением поддержки" для всех объектов ( Рис. 1.7 ).
1.7. Окно "Настройка правил поддержки"
Для объекта "УправлениеПредприятием", находящегося наверху списка (Рис.), необходимо задать режим поддержки "Редактируется с сохранением поддержки" и установить флажок "Установить для подчиненных объектов".
После этого в дереве конфигурации необходимо развернуть ветку "Планы обмена" и добавить новый план обмена "Полный".
  • 1.
    В состав нового плана обмена необходимо включить следующие элементы метаданных:
  • •
    Константы:
  • •
    Справочники:
  • •
    Документы:
  • •
    Планы видов характеристик:
  • •
    Регистры сведений:
  • •
    Регистры накопления:
  • 2.
    Для всех объектов метаданных, включенных в состав план обмена, необходимо включить авторегистрацию изменений. Пример ( Рис. 1.8 ):
    1.8. Включение авторегистрации для объектов
  • 3.
    В макеты созданного плана обмена следует добавить макет "ПравилаРегистрации" - пустой макет типа "Текстовый документ" ( Рис. 1.9 ).
    1.9. Окно "Конструктор макета"
  • 4.
    Включить добавленный план обмена в подсистему "СинхронизацияДанных" ( Рис. 1.10 ).
    1.10. Окно настройки плана обмена "Полный". Вкладка "Подсистемы".
  • 5.
    Сохранить конфигурацию.


Первоначальная выгрузка данных из "1С:Управление торговлей", ред. 10.3

Обработка предназначена для первоначальной выгрузки данных из основной учетной системы (конфигурации "Управление торговлей", ред.10.3) в конфигурацию "Агент Плюс: Управление дистрибуцией", ред.1.0.
Обмен данными между конфигурациями Управление торговлей и Агент Плюс: Управление дистрибуцией осуществляется с использованием механизма чтения измененных объектов из планов обмена. Для обмена с Агент Плюс: Управление дистрибуцией используется план обмена "Полный".
Для запуска обработки необходимо открыть внешний файл с названием "ПервоначальноеЗаполнение.epf".
На форме обработки находятся четыре закладки – "Первоначальная выгрузка НСИ", "Регистрация последних цен", "Срез последних остатков" и "Первоначальная выгрузка оборотов". На каждой закладке задаются необходимые настройки и выполняется выгрузка определенных данных из конфигурации Управление торговлей, ред.10.3.
Обмен данными всегда должен начинаться с первоначальной выгрузки нормативно-справочной информации (НСИ).
Первоначальная выгрузка НСИ
Первоначальная выгрузка данных из "1С:Управление торговлей", ред. 10.3
1.11. Окно обработки первоначальной выгрузки данных из УТ 10.3.
Вкладка "Настройка каталога и узла для обмена".
На закладке "Первоначальная выгрузка НСИ" задаются узлы плана обмена "Полный" ( Рис. 1.11 ).
Узел обмена с иконкой " [image] " является предопределенным и доступен в списке всегда. Такой узел считается основным и обозначает текущую информационную базу. Изначально он может не иметь ни кода, ни наименования. Для заполнения этих параметров необходимо нажать на кнопку "Заполнить основной". После заполнения основного узла кнопка становится недоступной.
Далее необходимо создать узел обмена, на котором будут регистрироваться изменения объектов для решения "Агент Плюс: Управление дистрибуцией". Для этого необходимо нажать на кнопку "Создать подчиненный". В результате чего будет создан узел обмена с наименованием Управление дистрибуцией и кодом УД. После того как создан узел, отличный от основного, на нем начинают регистрироваться изменения по объектам, входящим в состав плана обмена.
Для выгрузки данных при помощи механизма XDTO (XML Data Transfer Objects) следует установить флажок "Выгрузка через XDTO". Файл, выгруженный данным способом, загружается в "Агент Плюс: Управление дистрибуцией" при помощи обработки "Загрузка данных XDTO".
После нажатия кнопки "Далее>" для всех элементов справочника "Контрагенты" автоматически будет создан признак "Дистрибьютор". При этом откроется окно с напоминанием о необходимости установить флажок для признака "Дистрибьютор" для элементов справочника "Контрагенты", являющихся дистрибьюторами ( Рис. 1.12 ). Данные контрагенты будут загружены в "Управление дистрибуцией" в качестве подразделений.
Рис. 1.12. Окно обработки первоначальной выгрузки данных из УТ 10.3.
Вкладка "Выгрузка НСИ".
Для запуска выгрузки нормативно-справочной информации необходимо нажать на кнопку "Первоначальная выгрузка НСИ". В результате в каталоге, указанном в поле "Каталог выгрузки", будет сформирован файл обмена с названием "FromUT_first_data.zip".
Важно.
При выгрузке НСИ из учетной системы будет передана информация о дате первого контакта с торговыми точками, выгружаемыми в Агент Плюс: Управление дистрибуцией. Дата первого контакта передается в Агент Плюс: Управление дистрибуцией только при первоначальной выгрузке НСИ. При последующем обмене данными между учетной системой и Агент Плюс: Управление дистрибуцией, информация о дате первого контакта с торговыми точками не выгружается.
Регистрация последних цен
Следующий этап обмена данными между конфигурациями Управление торговлей и Агент Плюс: Управление дистрибуцией – выгрузка цен номенклатуры ( Рис. 1.13 ).
1.13. Окно обработки первоначальной выгрузки данных из УТ 10.3.
Вкладка "Регистрация последних цен".
Для выгрузки последних (актуальных) цен номенклатуры необходимо в форме обработки "Настройка параметров обмена УТ-УД" перейти на закладку "Регистрация последних цен", указать дату среза последних цен и нажать на кнопку "Далее>". В результате в каталоге, указанном в поле "Каталог выгрузки", будет сформирован файл обмена с названием "FromUT_last_prices.zip".
Срез последних остатков
После выгрузки цен номенклатуры необходимо выгрузить актуальные остатки товаров ( Рис. 1.14 ).
1.14. Окно обработки первоначальной выгрузки данных из УТ 10.3.
Вкладка "Срез последних остатков".
Для выгрузки актуальных остатков номенклатуры необходимо в форме обработки "Настройка параметров обмена УТ-УД" перейти на закладку "Срез последних остатков", указать дату среза остатков и нажать на кнопку "Далее>". В результате в каталоге, указанном в поле "Каталог выгрузки", будет сформирован файл обмена с названием "FromUT_last_rests.zip".
Важно.
Датой среза принимается дата, ранее которой гарантированно не будут изменяться документы, влияющие на остатки товаров и взаиморасчеты с клиентами.
Первоначальная выгрузка оборотов
Следующий этап обмена - первоначальная выгрузка оборотов продаж (документов "Корректировка остатков товаров") ( Рис. 1.15 ).
1.15. Окно обработки первоначальной выгрузки данных из УТ 10.3.
Вкладка "Первоначальная выгрузка оборотов".
Для выгрузки оборотов продаж необходимо в форме обработки "Настройка параметров обмена УТ-УД" перейти на закладку "Первоначальная выгрузка оборотов" и указать период выгрузки, за который будут выгружены документы "Корректировка остатков товаров". При нажатии на кнопку "Далее>", указанном в поле "Каталог выгрузки", будет сформирован файл обмена с названием "FromUT_docs_of_turnovers.zip".
Важно.
Дата начала периода выгрузки документов оборотов и дата среза последних остатков товаров должны совпадать.


Обмен данными с "1С:Управление торговлей", редакция 10.3

Сценарий обмена данными
Обмен данными между "1С:Управление торговлей", ред. 10.3 и "Агент Плюс: Управление дистрибуцией, ред.1.0" выполняется в виде XML-файла, упакованного в ZIP-архив. Передача файла может осуществляться посредством FTP-сервера или через каталог обмена на ПК.
1.16. Схема обмена данными между конфигурацией-источником и конфигурацией-получателем.
Поскольку обработка "Exchange Manager" используется как для выгрузки, так и для загрузки данных в учетную систему, процесс обмена данными описан с использованием терминов Источник и Получатель. Источником в данном случае является конфигурация, из которой выгружаются данные. А Получателем - конфигурация, в которую данные загружаются.
Обмен данными происходит по следующей схеме ( Рис. 1.16 ):
  • 1.
    Первоначально на Источнике обработка формирует файл выгрузки на диске с уникальным именем.
  • 2.
    После копирования на FTP-сервер, файл переименовывается в фиксированное имя. Если файл с таким названием уже существует на FTP-сервере, он заменяется.
  • 3.
    Перед загрузкой с FTP-сервера файл переименовывается Получателем на уникальный. На физический диск файл копируется с фиксированным именем. После успешного копирования файл на FTP-сервере удаляется.
  • 4.
    Получателем перед загрузкой файла в БД, файл переименовывается в уникальный. После он загружается в УС. После успешной загрузки файл удаляется.
В варианте обмена без использования FTP-сервера шаги 2 и 3 исключаются (показано на Рис. 1.16).
Описание обработки
Обработка предназначена для выгрузки/загрузки данных из/в конфигурацию "1С:Управление торговлей", ред. 10.3.
Обмен данными с "1С:Управление торговлей", редакция 10.3
1.17. Окно обработки обмена данными между УД и УТ 10.3.
На форме загрузки/выгрузки располагаются следующие кнопки и поля ( Рис. 1.17 ):
  • •
    Старт. Запускает процесс загрузки/выгрузки данных, который будет выполняться автоматически с периодичностью, указанной в настройке Интервал повторения (мин.).
  • •
    Стоп. Останавливает процесс загрузки/выгрузки данных.
  • •
    Вручную. Позволяет выполнить единичную загрузку/выгрузку данных.
  • •
    Интервал повторения (мин). В поле указывается интервал в минутах, через который будет автоматически производиться загрузка / выгрузка данных из указанных папок.
Важно!!!
Для непрерывной загрузки/выгрузки обработка должна быть всегда открыта в конфигурации!
Примечание.
Для одновременной работы загрузки и выгрузки должно быть запущено два сеанса конфигурации "Управление торговлей", ред. 10.3 под двумя пользователями – сеанс для выгрузки данных и сеанс для загрузки данных.
Обмен данными между конфигурациями "Управление торговлей", ред. 10.3 и "Агент Плюс: Управление дистрибуцией, ред.1.0" выполняется в виде XML-файлов, упакованных в ZIP-архив. Если выполняется выгрузка данных из Управление торговлей, ред. 10.3, то архив будет иметь название "FromUT.zip". Если выполняется загрузка данных в "Управление торговлей, ред. 10.3", то архив будет иметь название "FromUD.zip".
Настройки обработки
Перейти к настройкам обработки можно по кнопке [image] ("Настройки") на панели кнопок. Для доступа к настройкам необходимо ввести пароль в открывшейся форме ввода пароля и нажать на кнопку "Готово".
1.18. Форма настроек обработки ExchangeManager.
В результате откроется форма, на которой указываются следующие настройки ( Рис. 1.18 ):
  • •
    Настройки доступа:
  • •
    Пользователь загрузки. Указывается пользователь, от имени которого будет запущен сеанс для загрузки данных. Значение указывается из справочника "Пользователи". Если сеанс "1С:Предприятия" запущен от имени пользователя, указанного в этом поле, то при запуске обработки будет открываться форма загрузки данных в 1С.
  • •
    Пользователь выгрузки. Указывается пользователь, от имени которого будет запущен сеанс для выгрузки данных. Значение указывается из справочника "Пользователи". Если сеанс "1С:Предприятия" запущен от имени пользователя, указанного в этом поле, то при запуске обработки будет открываться форма выгрузки данных из 1С.
  • •
    Настройки подключения FTP:
  • •
    Использовать ФТП. Флажок регулирует возможность обмена данными через FTP-сервер. Если флажок установлен, то становятся доступными настройки FTP-сервера. Если флажок снят, то обмен данными будет выполняться через каталог загрузки/выгрузки.
  • •
    Сервер. Указывается адрес FTP-сервера.
  • •
    Пользователь. Указывается имя пользователя для авторизации на указанном FTP-сервере.
  • •
    Пароль. Указывается пароль пользователя для авторизации на указанном FTP-сервере.
  • •
    Пассивный режим. Флажок устанавливает режим соединения с FTP-сервером. Если флажок установлен, то соединение пассивное. Если флажок не установлен, то соединение активное.
  • •
    Проверка подключения. При нажатии на кнопку осуществляется попытка соединения с FTP-сервером с учетом заданных параметров. Результаты проверки подключения отображаются в поле "Служебные сообщения".
  • •
    Настройки загрузки:
  • •
    Каталог загрузки. Указывается путь к папке на ПК, в которой будет выполняться поиск файла FromUD.zip для загрузки в "Управление торговлей", ред. 10.3.
  • •
    Файл лога загрузки. Указывается путь к текстовому файлу, в котором будет фиксироваться информация о процессе загрузки данных, например, об ошибках обмена.
  • •
    Настройки выгрузки:
  • •
    Каталог выгрузки. Указывается путь к папке на ПК, в которой будет размещаться файл обмена данными перед загрузкой в "Агент Плюс: Управление дистрибуцией" или перед отправкой на FTP-сервер (если включен флажок "Использовать ФТП").
  • •
    Файл лога выгрузки. Указывается путь к текстовому файлу, в котором будет фиксироваться информация о процессе выгрузки данных.
  • •
    Узел для обмена. Указывается узел плана обмена, на котором регистрируются изменения объектов для решения "Агент Плюс: Управление дистрибуцией".
  • •
    Выгрузка через XDTO. Для выгрузки данных при помощи механизма XDTO (XML Data Transfer Objects) следует установить флажок "Выгрузка через XDTO". Файл, выгруженный данным способом, загружается в "Агент Плюс: Управление дистрибуцией" при помощи обработки "ExchangeAdapterUD.epf", при этом необходимо установить флажок "Загрузка через XDTO".
Для сохранения указанных настроек необходимо нажать на кнопку "Сохранить". После чего откроется форма выгрузки или загрузки данных, в зависимости от того, под каким пользователем запущен сеанс 1С (под пользователем загрузки или пользователем выгрузки).


Обмен данными с "1С:Управление торговлей", редакция 11.2

Сценарий обмена данными
Обмен данными между конфигурациями "1С:Управление торговлей, ред. 11.2" и "Агент Плюс: Управление дистрибуцией, ред.1.0" выполняется в виде XML-файла, упакованного в ZIP-архив. Передача файла может осуществляться посредством FTP-сервера или через каталог обмена на ПК.
1.19. Схема обмена данными между конфигурацией-источником и конфигурацией-получателем.
Поскольку обработка "Exchange Manager" используется как для выгрузки, так и для загрузки данных в конфигурацию "1С:Управление торговлей, ред. 11.2", процесс обмена данными описан с использованием терминов Источник и Получатель. Источником в данном случае является конфигурация, из которой выгружаются данные. А Получателем - конфигурация, в которую данные загружаются.
Обмен данными происходит по следующей схеме ( Рис. 1.19 ):
  • 1.
    Первоначально на Источнике обработка формирует файл выгрузки на диске с уникальным именем.
  • 2.
    После копирования на FTP-сервер, файл переименовывается в фиксированное имя. Если файл с таким названием уже существует на FTP-сервере, он заменяется.
  • 3.
    Перед загрузкой с FTP-сервера файл переименовывается Получателем на уникальный. На физический диск файл копируется с фиксированным именем. После успешного копирования файл на FTP-сервере удаляется.
  • 4.
    Получателем перед загрузкой файла в БД, файл переименовывается в уникальный. После он загружается в УС. После успешной загрузки файл удаляется.
В варианте обмена без использования FTP-сервера шаги 2 и 3 исключаются (показано на Рис. 1.19).
Описание обработки
Обработка предназначена для выгрузки/загрузки данных из/в конфигурацию "1С:Управление торговлей", ред. 11.2.
Обмен данными с "1С:Управление торговлей", редакция 11.2
1.20. Окно обработки "Менеджер универсального обмена XML"
На форме обработки необходимо указать следующие настройки ( Рис. 1.20 ):
  • •
    Интервал выгрузки. Указывается интервал времени в минутах, через который будет выполняться автоматическая выгрузка данных.
  • •
    Старт выгрузки. Запускает процесс выгрузки данных, который будет выполняться автоматически с периодичностью, указанной в настройке "Интервал выгрузки".
  • •
    Остановка выгрузки. Останавливает (прерывает) процесс выгрузки данных.
  • •
    Ручная выгрузка. Позволяет выполнить единичную выгрузку данных.
  • •
    Интервал загрузки. Указывается интервал времени в минутах, через который будет выполняться автоматическая загрузка данных.
  • •
    Старт загрузки. Запускает процесс загрузки данных, который будет выполняться автоматически с периодичностью, указанной в настройке "Интервал загрузки".
  • •
    Остановка загрузки. Останавливает (прерывает) процесс загрузки данных.
  • •
    Ручная загрузка. Позволяет выполнить единичную загрузку данных.
  • •
    Группа настройки хранения файлов обмена:
  • •
    Каталог загрузки. Указывается путь к папке на ПК, в которой будет выполняться поиск файла обмена данными для загрузки в конфигурацию "Управление торговлей, ред. 11.2".
  • •
    Каталог выгрузки. Указывается путь к папке на ПК, в которой будет размещаться файл обмена данными для загрузки в "Управление дистрибуцией" или перед отправкой на FTP-сервер (если включен флажок Использовать ФТП).
  • •
    Узел обмена. Указывается узел плана обмена, на котором регистрируются изменения объектов для "Управление дистрибуцией".
  • •
    Логирование:
  • •
    Файл лога загрузки. Указывается путь к текстовому файлу, в котором будет фиксироваться информация о процессе загрузки данных, например, об ошибках обмена.
  • •
    Файл лога выгрузки. Указывается путь к текстовому файлу, в котором будет фиксироваться информация о процессе выгрузки данных.
  • •
    Список адресов для отправки ошибок. Указывается список электронных адресов, на которые будут отправлены электронные письма с сообщениями об ошибках, возникающих в процессе обмена данными.
  • •
    Настройки FTP:
  • •
    Использовать ФТП. Флажок регулирует возможность обмена данными через FTP-сервер. Если флажок установлен, то становятся доступными настройки FTP-сервера. Если флажок снят, то обмен данными будет выполняться через каталог загрузки/выгрузки.
  • •
    Сервер. Указывается адрес FTP-сервера.
  • •
    Пользователь. Указывается имя пользователя для авторизации на указанном FTP-сервере.
  • •
    Пароль. Указывается пароль пользователя для авторизации на указанном FTP-сервере.
  • •
    Пассивный режим. Флажок устанавливает режим соединения с FTP-сервером. Если флажок установлен, то соединение пассивное. Если флажок не установлен, то соединение активное.
  • •
    Проверить соединение. При нажатии на кнопку осуществляется попытка соединения с FTP-сервером с учетом заданных параметров. Результаты проверки подключения отображаются в поле "Служебные сообщения".
Для сохранения указанных настроек необходимо нажать на кнопку "Сохранить". После чего откроется форма выгрузки или загрузки данных, в зависимости от того, под каким пользователем запущен сеанс 1С (под пользователем загрузки или пользователем выгрузки).


Обмен данными с "1С:ERP Управление предприятием 2"

Сценарий обмена данными
Обмен данными между конфигурациями "1С:ERP Управление предприятием 2" и "Агент Плюс: Управление дистрибуцией, ред.1.0" выполняется в виде XML-файла, упакованного в ZIP-архив. Передача файла может осуществляться посредством FTP-сервера или через каталог обмена на ПК.
1.21. Схема обмена данными между конфигурацией-источником и конфигурацией-получателем.
Поскольку обработка "Exchange Manager" используется как для выгрузки, так и для загрузки данных в конфигурацию "1С:ERP Управление предприятием 2", процесс обмена данными описан с использованием терминов Источник и Получатель. Источником в данном случае является конфигурация, из которой выгружаются данные. А Получателем - конфигурация, в которую данные загружаются.
Обмен данными происходит по следующей схеме ( Рис. 1.21 ):
  • 1.
    Первоначально на Источнике обработка формирует файл выгрузки на диске с уникальным именем.
  • 2.
    После копирования на FTP-сервер, файл переименовывается в фиксированное имя. Если файл с таким названием уже существует на FTP-сервере, он заменяется.
  • 3.
    Перед загрузкой с FTP-сервера файл переименовывается Получателем на уникальный. На физический диск файл копируется с фиксированным именем. После успешного копирования файл на FTP-сервере удаляется.
  • 4.
    Получателем перед загрузкой файла в БД, файл переименовывается в уникальный. После он загружается в УС. После успешной загрузки файл удаляется.
В варианте обмена без использования FTP-сервера шаги 2 и 3 исключаются (показано на рисунке).
Описание обработки
Обработка предназначена для выгрузки/загрузки данных из/в конфигурацию "1С:ERP Управление предприятием 2".
Обмен данными с "1С:ERP Управление предприятием 2"
1.22. Окно обработки "Менеджер универсального обмена XML"
На форме обработки необходимо указать следующие настройки ( Рис. 1.22 ):
  • •
    Интервал выгрузки. Указывается интервал времени в минутах, через который будет выполняться автоматическая выгрузка данных.
  • •
    Старт выгрузки. Запускает процесс выгрузки данных, который будет выполняться автоматически с периодичностью, указанной в настройке "Интервал выгрузки".
  • •
    Остановка выгрузки. Останавливает (прерывает) процесс выгрузки данных.
  • •
    Ручная выгрузка. Позволяет выполнить единичную выгрузку данных.
  • •
    Интервал загрузки. Указывается интервал времени в минутах, через который будет выполняться автоматическая загрузка данных.
  • •
    Старт загрузки. Запускает процесс загрузки данных, который будет выполняться автоматически с периодичностью, указанной в настройке "Интервал загрузки".
  • •
    Остановка загрузки. Останавливает (прерывает) процесс загрузки данных.
  • •
    Ручная загрузка. Позволяет выполнить единичную загрузку данных.
  • •
    Группа настройки хранения файлов обмена:
  • •
    Каталог загрузки. Указывается путь к папке на ПК, в которой будет выполняться поиск файла обмена данными для загрузки в конфигурацию "1С:ERP Управление предприятием 2".
  • •
    Каталог выгрузки. Указывается путь к папке на ПК, в которой будет размещаться файл обмена данными для загрузки в "Управление дистрибуцией" или перед отправкой на FTP-сервер (если включен флажок Использовать ФТП).
  • •
    Узел обмена. Указывается узел плана обмена, на котором регистрируются изменения объектов для "Управление дистрибуцией".
  • •
    Логирование:
  • •
    Файл лога загрузки. Указывается путь к текстовому файлу, в котором будет фиксироваться информация о процессе загрузки данных, например, об ошибках обмена.
  • •
    Файл лога выгрузки. Указывается путь к текстовому файлу, в котором будет фиксироваться информация о процессе выгрузки данных.
  • •
    Список адресов для отправки ошибок. Указывается список электронных адресов, на которые будут отправлены электронные письма с сообщениями об ошибках, возникающих в процессе обмена данными.
  • •
    Настройки FTP:
  • •
    Использовать ФТП. Флажок регулирует возможность обмена данными через FTP-сервер. Если флажок установлен, то становятся доступными настройки FTP-сервера. Если флажок снят, то обмен данными будет выполняться через каталог загрузки/выгрузки.
  • •
    Сервер. Указывается адрес FTP-сервера.
  • •
    Пользователь. Указывается имя пользователя для авторизации на указанном FTP-сервере.
  • •
    Пароль. Указывается пароль пользователя для авторизации на указанном FTP-сервере.
  • •
    Пассивный режим. Флажок устанавливает режим соединения с FTP-сервером. Если флажок установлен, то соединение пассивное. Если флажок не установлен, то соединение активное.
  • •
    Проверить соединение. При нажатии на кнопку осуществляется попытка соединения с FTP-сервером с учетом заданных параметров. Результаты проверки подключения отображаются в поле "Служебные сообщения".
Для сохранения указанных настроек необходимо нажать на кнопку "Сохранить". После чего откроется форма выгрузки или загрузки данных, в зависимости от того, под каким пользователем запущен сеанс 1С (под пользователем загрузки или пользователем выгрузки).


Обработка для загрузки/выгрузки данных на стороне "Агент Плюс:Управление дистрибуцией"

Сценарий обмена данными
Обмен данными между учетными системами и "Агент Плюс: Управление дистрибуцией, ред.1.0" выполняется в виде XML-файла, упакованного в ZIP-архив. Передача файла может осуществляться посредством FTP-сервера или через каталог обмена на ПК.
1.23 Схема обмена данными между конфигурацией-источником и конфигурацией-получателем.
Поскольку обработка "ExchangeAdapterUD.epf" используется как для выгрузки, так и для загрузки данных в конфигурацию "Агент Плюс: Управление дистрибуцией, ред.1.0", процесс обмена данными описан с использованием терминов Источник и Получатель. Источником в данном случае является конфигурация, из которой выгружаются данные. А Получателем - конфигурация, в которую данные загружаются.
Обмен данными происходит по следующей схеме ( Рис. 1.23 ):
  • 1.
    Первоначально на Источнике обработка формирует файл выгрузки на диске с уникальным именем.
  • 2.
    После копирования на FTP-сервер, файл переименовывается в фиксированное имя. Если файл с таким названием уже существует на FTP-сервере, он заменяется.
  • 3.
    Перед загрузкой с FTP-сервера файл переименовывается Получателем на уникальный. На физический диск файл копируется с фиксированным именем. После успешного копирования файл на FTP-сервере удаляется.
  • 4.
    Получателем перед загрузкой файла в БД, файл переименовывается в уникальный. После он загружается в УС. После успешной загрузки файл удаляется.
В варианте обмена без использования FTP-сервера шаги 2 и 3 исключаются (показано на Рис. 1.23).
Описание обработки
Обработка предназначена для выгрузки/загрузки данных из/в конфигурацию "Агент Плюс: Управление дистрибуцией, ред. 1.0".
Обработка для загрузки/выгрузки данных на стороне "Агент Плюс:Управление дистрибуцией"
Рис. 1.24. Адаптер универсальный обмен XML
На форме обработки необходимо указать следующие настройки ( Рис. 1.24 ):
  • •
    Интервал выгрузки. Указывается интервал времени в минутах, через который будет выполняться автоматическая выгрузка данных.
  • •
    Старт выгрузки. Запускает процесс выгрузки данных, который будет выполняться автоматически с периодичностью, указанной в настройке "Интервал выгрузки".
  • •
    Остановка выгрузки. Останавливает (прерывает) процесс выгрузки данных.
  • •
    Ручная выгрузка. Позволяет выполнить единичную выгрузку данных.
  • •
    Интервал загрузки. Указывается интервал времени в минутах, через который будет выполняться автоматическая загрузка данных.
  • •
    Старт загрузки. Запускает процесс загрузки данных, который будет выполняться автоматически с периодичностью, указанной в настройке "Интервал загрузки".
  • •
    Остановка загрузки. Останавливает (прерывает) процесс загрузки данных.
  • •
    Ручная загрузка. Позволяет выполнить единичную загрузку данных.
  • •
    Группа настройки хранения файлов обмена:
  • •
    Каталог загрузки. Указывается путь к папке на ПК, в которой будет выполняться поиск файла обмена данными для загрузки в конфигурацию "Управление дистрибуцией".
  • •
    Каталог выгрузки. Указывается путь к папке на ПК, в которой будет размещаться файл обмена данными "FromUD.zip" для загрузки в учетную систему, с которой происходит обмен, или перед отправкой на FTP-сервер (если включен флажок "Использовать ФТП").
  • •
    Узел обмена. Указывается узел плана обмена, на котором регистрируются изменения объектов. Необходимо выбрать тип обмена "Обмен с Управление торговлей" и в открывшемся окне создать новый узел обмена или выбрать уже имеющийся.
Примечание.
При создании плана требуется задать только наименование узла обмена и код узла на закладке "Служебная информация".
  • •
    Логирование:
  • •
    Файл лога загрузки. Указывается путь к текстовому файлу, в котором будет фиксироваться информация о процессе загрузки данных, например, об ошибках обмена.
  • •
    Файл лога выгрузки. Указывается путь к текстовому файлу, в котором будет фиксироваться информация о процессе выгрузки данных.
  • •
    Список адресов для отправки ошибок. Указывается список электронных адресов, на которые будут отправлены электронные письма с сообщениями об ошибках, возникающих в процессе обмена данными.
  • •
    Настройки FTP:
  • •
    Использовать ФТП. Флажок регулирует возможность обмена данными через FTP-сервер. Если флажок установлен, то становятся доступными настройки FTP-сервера. Если флажок снят, то обмен данными будет выполняться через каталог загрузки/выгрузки.
  • •
    Сервер. Указывается адрес FTP-сервера.
  • •
    Пользователь. Указывается имя пользователя для авторизации на указанном FTP-сервере.
  • •
    Пароль. Указывается пароль пользователя для авторизации на указанном FTP-сервере.
  • •
    Пассивный режим. Флажок устанавливает режим соединения с FTP-сервером. Если флажок установлен, то соединение пассивное. Если флажок не установлен, то соединение активное.
  • •
    Проверить соединение. При нажатии на кнопку осуществляется попытка соединения с FTP-сервером с учетом заданных параметров. Результаты проверки подключения отображаются в поле "Служебные сообщения".
  • •
    Параметры обмена
  • •
    Проводить документы. Флажок устанавливает проведение документов при загрузке. Если флажок установлен, то документы будут проводиться при загрузке. Если флажок не установлен, то документы будут записываться, а проведение документов будет осуществляться вручную.
  • •
    Конфигурация приемник. При нажатии на гиперссылку "Изменить" открывается диалоговое окно выбора типа конфигурации, с которой осуществляется обмен. Доступны следующие значения: "Управление торговлей 10.3", "Управление торговлей 11.2", "ERP Управление предприятием 2.1".
Для сохранения указанных настроек необходимо нажать на кнопку "Сохранить".


Фоновый обмен данными в УД

Для настройки фонового обмена данными используется типовой механизм регламентных заданий 1С Предприятие. Для того чтобы настроить обмен в фоновом режиме, необходимо создать регламентное задание для обработки "ExchangeAdapterUD.epf". Использование дополнительных обработок регулируется опцией "Дополнительные отчеты и обработки" в подсистеме "Администрирование - Печатные формы и обработки" ( Рис. 1.25 ).
Рис. 1.25 Адаптер универсальный обмен XML
После включения данной опции (установки флажка) станет доступна гиперссылка "Дополнительные отчеты и обработки" ( Рис. 1.26 ).
Рис. 1.26. Адаптер универсальный обмен XML
В окне со списком дополнительных отчетов и обработок следует нажать на кнопку "Создать". В открывшемся окне следует загрузить данные из файла внешней обработки "ExchangeAdapterUD.epf" ( Рис. 1.27 ).
В окне обработки настраивается расписание, размещение в подсистемах и список пользователей, для которых будет доступна обработка.
Рис. 1.27. Адаптер универсальный обмен XML
После этого в список регламентных и фоновых заданий будут добавлены задания на выгрузку данных для учетной системы и на загрузку данных из учетной системы ( Рис. 1.28 ).
Рис. 1.28. Адаптер универсальный обмен XML


Почему в папке обмена между УД и УС формируется файл "TicketFromUD.txt" и для чего он?

Во время обмена между "Управление дистрибуцией" и основной учетной системой организации формируется временный файл "TicketFromUD.txt". Данный файл является ответным файлом подтверждения загрузки файла обмена данными в конфигурацию. В файле содержится имя и идентификатор метаданных, которые содержались в файле обмена.


2. Инструкция по настройке консолидации данных по вторичным продажам

В системе "Агент плюс: Управление дистрибуцией" (релиз 1.0.2.1 и выше) поддерживается механизм консолидации данных по вторичным продажам от дистрибьюторов.
Для того чтобы осуществить сбор данных по вторичным продажам от дистрибьюторов, необходимо выполнить следующие шаги:
  • a.
    Произвести сопоставление номенклатуры;
  • b.
    Настроить выгрузку данных по продажам на стороне дистрибьютора/филиала;
  • c.
    Настроить загрузку данных на стороне УД.
Под вторичными продажами понимаются продажи дистрибьютора конечному потребителю ( Рис. 2.1 ).
Рис. 2.1. Различные типы продаж


Как выделить дистрибьютора в БД УД?

Согласно рекомендации для начала в основной учетной системе необходимо указать логический признак для контрагента/партнера – "Дистрибьютор" (см. документ "Руководство пользователя "Агент Плюс: Управление дистрибуцией"").
После этого все контрагенты/партнеры с указанным признаком "Дистрибьютор" будут записаны в УД в качестве подразделений в структуре предприятия с соответствующим наименованием.
Примечание.
Данные контрагенты/партнеры будут также продублированы в качестве торговых точек в системе УД.
Логический признак "Дистрибьютор" для контрагента/партнера (в зависимости от конфигурации основной учетной системы) автоматически появится в качестве дополнительного сведения в основной учетной системе при инициализации обработки "Первоначальное заполнение.epf".
Важно отметить, что все дистрибьюторы в УД считаются подразделениями в структуре предприятия (предопределенная группа "Дистрибьюторы"), и код элемента справочника "Подразделения" должен быть сообщен дистрибьютору для настройки синхронизации с "Управление дистрибуцией" ( Рис. 2.2 ).
Рис. 2.2. Код элемента справочника "Подразделения"


Что необходимо сделать, чтобы получать данные от дистрибьюторов?

Для того чтобы получать данные по вторичным продажам, необходимо на стороне дистрибьютора обеспечить выгрузку в утвержденном формате (см. документ "Формат обмена вторичных продаж", входящий в комплект поставки).
"Агент плюс: Управление дистрибуцией" поддерживает выгрузку и загрузку данных по вторичным продажам в автоматическом режиме.
Для получения данных из систем дистрибьютора в автоматическом режиме необходимо настроить обмен с помощью специальных обработок, входящих в комплект поставки УД. Обработки, используемые на стороне дистрибьютора, могут отличаться в зависимости от типа учетной системы.
Примечание.
Механизм консолидации данных доступен, начиная с версии "Агент Плюс : Управление дистрибуцией" Стандарт.
В комплект поставки входят внешние обработки для выгрузки данных о вторичных продажах дистрибьютора для следующих типовых конфигураций "1С:Предприятие":
  • •
    "1С: Управление торговлей, редакция 10.3";
  • •
    "1С: Управление торговлей, редакция 11.2";
  • •
    "1С:ERP Управление предприятием 2".


Какова последовательность действий для настройки обмена между УД и УС Дистрибьютора?

Для настройки обмена необходимо выполнить следующую последовательность действий:
  • •
    Сообщить дистрибьютору его код согласно данным в УД ( Рис. 2.2 )
  • •
    На стороне дистрибьютора при запуске обработки "Подбор и выгрузка НСИ и данных по продажам" указать полученный код дистрибьютора;
  • •
    Произвести при помощи обработки "Подбор и выгрузка НСИ и данных по продажам" сопоставление (мэппинг) номенклатуры дистрибьютора и поставщика;
  • •
    Настроить выгрузку данных по продажам обработкой "Подбор и выгрузка НСИ и данных по продажам" на стороне дистрибьютора/филиала;
  • •
    Настроить загрузку данных при помощи обработки "Сопоставление данных из XML" на стороне "Управление дитрибуцией;
  • •
    Загрузить полученный от дистрибьютора файл сопоставления.


Как произвести сопоставление номенклатуры поставщика и дистрибьютора?

Рассмотрим процедуру на примере выгрузки справочника "Номенклатура" из "1С:Управление торговлей, редакция 11.2".
На форме обработки "Подбор и выгрузка НСИ и данных по продажам" ( Рис. 2.3 ) дистрибьютору необходимо выполнить следующие действия:
Рис. 2.3. Обработка "Подбор и выгрузка НСИ и данных о продажах"
  • 1.
    В поле "Настройка выгрузки" выбрать пункт "Номенклатура";
  • 2.
    Перейти на вкладку "Настройки отбора" и указать при необходимости дополнительные фильтры (к примеру, по коду номенклатуры);
  • 3.
    Вызвать процедуру "Найти объекты". Найденная номенклатура отобразиться на вкладке "Найденные объекты";
  • 4.
    Убедиться в корректности выгружаемых данных, указать каталог обмена и выгрузить номенклатуру, нажав на кнопку "Выгрузить данные".
  • 5.
    После этого в каталоге обмена будет сформирован файл "GoodsMapping.zip".
Производитель должен загрузить полученный архив с файлом обмена для сопоставления товара, для этого ему необходимо открыть в "Управление дистрибуцией" обработку "Сопоставление данных из XML" ( Рис. 2.4 ) и выполнить следующие действия:
  • 1.
    Во вкладке "Сопоставление" открыть файл "GoodsMapping.zip". Для этого следует нажать на кнопку "Открыть файл сопоставления" и выбрать каталог на локальном диске или на FTP-сервере, в котором находится архив с выгруженными от дистрибьютора данными. Вид справочника будет определен автоматически.
  • 2.
    В табличной части вкладки отобразится список номенклатуры.
  • 3.
    Необходимо выбрать поле для сопоставления и вызвать процедуру по кнопке "Искать".
    Рис. 2.4. Обработка "Сопоставление данных из XML"
    Сопоставление можно также произвести вручную. Для этого необходимо дважды нажать на поле "Ссылка на объект" в табличной части и выбрать соответствующую номенклатуру из списка имеющихся товаров.
  • 4.
    После завершения сопоставления следует нажать на кнопку "Сохранить сопоставление".
  • 5.
    При загрузке данных об остатках в "Агент Плюс: Управление дистрибуцией" может возникнуть ситуация, когда некоторые товары не были сопоставлены с данными в базе.
    Если в документах продаж были найдены ссылки на товары, которые не удалось сопоставить с данными в базе "Агент Плюс: Управление дистрибуцией", то будет выведено сообщение "Найдены несопоставленные данные! Загрузка остатков товаров невозможна!". При этом список несопоставленной номенклатуры будет автоматически записан в файл "NotMappedGoods.txt" и отправлен на адрес электронной почты, указанный в поле "Учетная запись электронной почты" на закладке "Настройки автозагрузки". Записать данные об остатках товаров в базу "Агент Плюс: Управление дистрибуцией" не получится до тех пор, пока из учетной системы дистрибьютора не будут переданы несопоставленные товары.


Как настроить выгрузку данных из учетной системы дистрибьютора по расписанию?

Данные из информационной базы дистрибьютора могут отправляться в "Агент Плюс: Управление дистрибуцией" автоматически, если в качестве основной учетной системы организации используется "1с: Управление торговлей, 11.2" или "1С:ERP Управление предприятием 2". Для этого используется встроенный механизм регламентных заданий.
Для настройки автоматической выгрузки данных необходимо выполнить следующие действия ( Рис. 2.5 ):
  • •
    Добавить обработку "Подбор и выгрузка НСИ и данных о продажах" в список дополнительных обработок 1С:Предприятия ("НСИ и Администрирование – Печатные формы, отчеты и обработки – Дополнительные отчеты и обработки").
  • •
    Открыть дополнительную обработку и в поле "Публикация" выбрать значение "Используется". Далее, указать на закладке "Команды" расписание выполнения регламентных заданий. Для того чтобы задать расписание выполнения команды необходимо установить флажок в колонке "Расписание" и в открывшемся окне задать необходимые значения настроек.
Рис. 2.5. Окно сохранения обработки в "Управление торговлей, ред. 11.2"
  • •
    После указания расписания выполнения регламентных заданий необходимо запустить обработку "Подбор и выгрузка НСИ и данных о продажах" из той подсистемы, которая была задана в поле "Размещение" ("Дополнительные обработки" в окне подсистемы).
  • •
    На форме обработки необходимо заполнить настройки "Код дистрибьютора" и "Каталог выгрузки".
  • •
    После чего в табличной части обработки на закладке "Настройки автовыгрузки" нажать на кнопку "Записать настройки".
При выборе значения "Данные по продажам" в поле "Настройка выгрузки" на закладке "Настройки автозагрузки" становится доступной настройка "Выгружать продажи за последние ... (дни)" ( Рис. 2.6 ). В данной настройке указывается количество дней, за которые необходимо выгрузить данные по продажам из учетной системы дистрибьютора.
Рис. 2.6. Обработка "Подбор и выгрузка НСИ и данных о продажах". Вкладка "Настройки автовыгрузки"


Как настроить автоматическую загрузку данных в Управление дистрибуцией по расписанию?

Данные из информационной базы дистрибьютора могут загружаться в "Агент Плюс: Управление дистрибуцией" автоматически. Для этого используется встроенный механизм регламентных заданий.
Для настройки автоматической загрузки данных необходимо выполнить следующие действия:
  • 1.
    Добавить обработку "Сопоставление данных из XML" в список дополнительных обработок 1С:Предприятия ("Администрирование – Печатные формы, отчеты и обработки – Дополнительные отчеты и обработки").
  • 2.
    Открыть дополнительную обработку и в поле "Публикация" выбрать значение "Используется" ( Рис. 2.7 ). Далее, указать на закладке "Команды" расписание выполнения регламентных заданий. Для того чтобы задать расписание выполнения команды необходимо установить флажок в колонке "Расписание" и в открывшемся окне задать необходимые значения настроек.
    Рис. 2.7. Окно сохранения обработки в "Управление дистрибуцией"
  • 3.
    После указания расписания выполнения регламентного задания необходимо выбрать из списка обработок "Настройки загрузки данных по вторичным продажам" в той подсистеме, которая была задана в поле "Размещение". На открывшейся форме обработки на закладке "Настройки автозагрузки" следует указать значения в настройках и записать их.
На закладке "Настройки автозагрузки" выполняется настройка автоматической загрузки данных по продажам дистрибьютора.
На закладке "Настройки автозагрузки" находятся следующие настройки:
  • •
    Каталог загрузки. В поле указывается папка на локальном или сетевом диске, в которой будет выполняться поиск файла для загрузки.
  • •
    Использовать ФТП. Флажок регулирует возможность автоматической загрузки данных с FTP-сервера. Если флажок установлен, то становятся доступными настройки FTP-сервера. Если флажок снят, то загрузка данных будет выполняться через Каталог загрузки.
  • •
    Пассивный режим ФТП. Флажок устанавливает режим соединения с FTP-сервером. Если флажок установлен, то соединение пассивное. Если флажок не установлен, то соединение активное.
  • •
    Сервер ФТП. В поле указывается адрес FTP-сервера.
  • •
    Каталог продаж. В поле указывается каталог пользователя на FTP-сервере.
  • •
    Пользователь ФТП. Указывается имя пользователя для авторизации на указанном FTP-сервере.
  • •
    Пароль ФТП. Указывается пароль пользователя для авторизации на указанном FTP-сервере.
  • •
    Проверить соединение. При нажатии на кнопку осуществляется попытка соединения с FTP-сервером с учетом заданных параметров. Результаты проверки подключения отображаются в "Служебных сообщениях".
Для сохранения указанных настроек необходимо нажать на кнопку "Записать настройки". После записи настроек обработка "Сопоставление данных из XML" будет сканировать указанный каталог на локальном диске или FTP-сервере согласно заданному расписанию обработки и автоматически загружать данные в "Агент Плюс: Управление дистрибуцией".
При автозагрузке данных о продажах также выполняется сопоставление товаров и контрагентов, указанных в документах продаж, с данными в базе "Агент Плюс: Управление дистрибуцией". Если какие-то данные из файла не были сопоставлены, то обработка автоматически сформирует файл со списком несопоставленных объектов в каталоге загрузки на локальном диске или FTP-сервере.


Что делать, если в момент загрузки были найдены несопоставленные позиции номенклатуры?

Если система обнаружит несопоставленные позиции номенклатуры при загрузке данных от дистрибьютора, загрузка вторичных продаж остановится, и будет сформирован файл со списком несопоставленных объектов. Администраторам со стороны производителя и дистрибьютора будет отправлено письмо с уведомлением на адрес электронной почты, указанный на вкладке "Настройки автозагрузки".
Дистрибьютору необходимо загрузить файл со списком несопоставленных объектов, проанализировать его, и если в нем указаны позиции другого поставщика, исключить их из отбора для выгрузки данных. Если они принадлежат данному поставщику, то следует откорректировать либо наименование, либо артикул, согласно требованиям поставщика.


Каким образом данные по вторичным продажам хранятся в "Управление дистрибуцией"?

Данные по вторичным продажам хранятся в "Управление дистрибуцией" в виде документов "Реализация товаров и услуг" со статусом "Загружен от дистрибьютора" ( Рис. 2.8 ). Статус документа отображается на вкладке "О документе".
Рис. 2.8. Окно документа "Реализация товаров". Вкладка "О документе"
В поле "Подразделение" в таких документах указывается подразделение, имеющее в "Управление дистрибуцией" признак "Дистрибьютор".
Примечание:
Данные документы не выгружаются в основную учетную систему производителя.


Как контролировать остатки на складах дистрибьютора?

Контроль и анализ остатков на складах клиента осуществляется при помощи отчета "Анализ движений товаров у дистрибьюторов" ( Рис. 2.9 ).
Отчет строится на основании данных документов "Отгрузка дистрибьютору", "Возврат от дистрибьютора", и "Корректировка остатков дистрибьютора", в котором загружаются данные о вторичных продажах
Для корректной работы отчета сперва необходимо настроить работу справочника "Виды операций дистрибьюторов".
Рис. 2.9. Справочник "Виды операций дистрибьюторов"
Перед формированием отчета необходимо заполнить справочник "Виды операций дистрибьюторов" и распределить виды операций по группам, указав для каждой группы действие, выполняемое при сверке данных в отчете ( Рис. 3.2 ).
Справочник заполнен предопределенными элементами, которые соотносятся с регистраторами движений товаров в регистре сведений "ТоварыНаСкладах" в учетной системе дистрибьютора.
Наименование вида операции формируется в зависимости от типа учетной системы, для которой он используется. Для "1С:Управление торговлей, ред. 10.3" название вида операции формируется из названия метаданных регистратора и вида операции. Для "1С:Управление торговлей, ред. 11.2" название вида операции формируется из названия регистратора и названия складской операции/типа операции.
Во время загрузки данных от дистрибьютора в "Управление дистрибуцией" могут быть использованы виды операций, которые не были зафиксированы в справочнике "Виды операций дистрибьюторов" ранее. Такие виды операций по умолчанию автоматически записываются в предопределенную группу операций "Несопоставленные".
Рис. 2.10. Окно элемента справочника "Виды операций дистрибьюторов"
После того, как виды операций были соотнесены с колонками отчета, следует сформировать отчет ( Рис. 2.11 ).
Как контролировать остатки на складах дистрибьютора?
Рис. 2.11. Отчет "Анализ движений товаров у дистрибьюторов"
Информация в табличной части отчета будет детализирована по дистрибьютору, номенклатуре и дате документа, зарегистрировавшего движение.
Количество и наименование колонок в отчете зависит от количества типов операций, зарегистрированных в документах "Корректировка остатков дистрибьютора". По умолчанию отображаются колонки "Начальный остаток", "Приход", "Расход", "Конечный остаток" и колонки сверки данных из документов "Корректировка остатков дистрибьютора" с документами "Отгрузка дистрибьютору" и "Возврат от дистрибьютора" ( Рис. 2.11 ).
Колонки с данными, для видов операций которых установлено сопоставление с отгрузками дистрибьютору, будут выделены желтым цветом. Колонки с данными, для видов операций которых установлено сопоставление с возвратами от дистрибьютора, будут выделены голубым цветом.
Данные в колонках "Отгрузка дистрибьютору" и "Возврат от дистрибьютора" могут быть выделены красным цветом ( Рис. 2.11 ), если при сопоставлении данных о движениях товаров у дистрибьютора и документов о продажах и возвратах дистрибьютора выявлено несоответствие данных.
При двойном нажатии на поле в колонках движения прихода или расхода открывается вариант отчета "Анализ движений товаров дистрибьюторов с детализацией вида операции" с фильтром по номенклатуре и дате поля ( Рис. 2.12 ). Также переключение между вариантами отчета доступно на вкладке "Другие отчеты".
Рис. 2.12 Отчета "Анализ движений товаров у дистрибьюторов с детализацией вида операции"


Как проанализировать продажи дистрибьютора?

Продажи дистрибьютора могут быть проанализированы при помощи отчета "Обороты продаж", вариант "По подразделениям". В настройках отчета следует выбрать подразделение-дистрибьютора, указать период продаж и в поле "Вторичные продажи" установить флажок и выбрать вариант "Да" ( Рис. 2.13 ).
Как проанализировать продажи дистрибьютора?
Рис. 2.13. Отчет "Обороты продаж (по подразделениям)"


Как просмотреть документы отгрузки дистрибьютору?

Документы "Отгрузка дистрибьютору" ( Рис. 2.14 ) – это документы реализации товаров, в которых оформляется оптовая отгрузка товара дистрибьютору. Документы загружаются в "Управление дистрибуцией" при помощи внешней обработки обмена данными с учетной системой и относятся к первичным продажам.
Документы "Отгрузка дистрибьютору" доступны для просмотра в отдельном журнале документов в подсистеме "Оперативные документы".
Как просмотреть документы отгрузки дистрибьютору?
Рис. 2.14. Документ "Отгрузка дистрибьютору"


Как просмотреть документы возвратов от дистрибьютора?

Документ "Возврат от дистрибьютора" ( Рис. 2.15 ) предназначен для регистрации в системе факта возврата товаров дистрибьютором на склад производителя.
Документы загружаются в "Управление дистрибуцией" из основной учетной системы при помощи обработки обмена и относятся к первичным продажам.
Документы "Отгрузка дистрибьютору" доступны для просмотра в отдельном журнале документов в подсистеме "Оперативные документы".
Как просмотреть документы возвратов от дистрибьютора?
Рис. 2.15. Документ "Возврат от дистрибьютора"
Примечание.
Документы "Возврат от дистрибьютора" не следует путать с документами "Возврат товаров от клиента" со статусом "Загружен от дистрибьютора". Первый документ относится к первичным продажам, он документирует отгрузку товара производителем дистрибьютору и загружается из основной учетной системы производителя. Второй – это документ вторичных продаж, который фиксирует возвраты клиентов дистрибьютора, и загружается из учетной системы дистрибьютора в "Управление дистрибуцией" (не попадая в основную учетную систему производителя).


3. Настройка обмена с МУ

Для того чтобы настроить обмен с между "Управление дистрибуцией" и мобильным устройством следует:
  • •
    Указать способ обмена данными в разделе "Общие настройки обмена с МУ";
  • •
    Создать сотрудника, обязательно указать статус сотрудника "Работает", а затем указать для него статус "Использует МУ" (иначе выгрузка на мобильное устройство будет невозможна);
  • •
    Создать и указать персональную настройку обмена для сотрудника (поле "Настройки обмена" на Рис. );
  • •
    Создать мобильное устройство для агента, указав идентификатор СОД, и закрепить его за ним;
  • •
    Создать на МУ настройку обмена, указав соответствующие параметры подключения;
  • •
    Обменяться данными с мобильным устройством агента, выгрузив данные из "Управление дистрибуцией" и загрузив их на МУ агента.


Как добавить новое мобильное устройство?

Для того чтобы создать новое мобильное устройство следует в подсистеме "Обмена с мобильными устройствами" выбрать раздел "Служебные справочники" и открыть справочник "Мобильные устройства".
Как добавить новое мобильное устройство?
Рис. 3.16. Подсистема "Обмен с мобильными устройствами"
  • 1.
    В открывшемся окне справочника "Мобильные справочники" следует нажать на кнопку "Создать". Для удобства мобильные устройства могут быть объединены в группы.
    Рис. 3.17. Окно справочника "Мобильные устройства"
  • 2.
    Для нового мобильного устройства следует указать наименование и идентификатор. Данные поля являются обязательными для заполнения.
Рис. 3.18. Окно элемента справочника "Мобильные устройства"


Как настроить обмен данными через Агент Плюс СОД?

Для обмена данными при помощи службы "Агент Плюс СОД" (ссылка на скачивание службы и документации: http://agentplus.ru/download/aps_app.zip) требуется:
  • 1.
    Запустить службу "Агент Плюс СОД" и настроить её согласно инструкции.
  • 2.
    В конфигурации "Управление дистрибуцией" в разделе "Общие настройки обмена данными с мобильными устройствами" на закладке "Способ обмена" ( Рис. 3.1 ) выполнить следующие действия:
  • a.
    Установить "Агент плюс СОД" способом обмена по умолчанию.
  • b.
    В поле "Адрес службы обмена" указать адрес сервера, на котором запущена служба (может быть указано как имя компьютера в локальной сети, например, "apserver", так и IP-адрес, например, "192.168.0.1").
  • c.
    В поле "Порт" указать номер порта сервера, на котором запущена служба (по умолчанию это порт 5555).
  • d.
    В поле "Папка обмена" указать название папки для обмена с помощью службы "Агент Плюс СОД". Может быть указана как локальная, так и сетевая папка.
  • e.
    При нажатии на кнопку "Генерация файла настроек" создается XML-файл с настройками для службы Агент Плюс СОД.
    Как настроить обмен данными через Агент Плюс СОД?
Рис. 3.1. Общие настройки обмена данными с МУ. Вкладка "Способ обмена данными"
  • 1.
    Сохранить изменения, нажав на кнопку "Записать и закрыть".
  • 2.
    В обработке "Обмен данными с мобильными устройствами" на закладке "Обмен данными" ( Рис. 3.2 ) указать подразделение и агента, для которых будут выгружены данные. Если в поле агент значение не указано, то данные будут выгружены для всех агентов указанного подразделения. Если не указан агент и подразделение, то данные будут выгружены для всех агентов.
    Рис. 3.2. Обработка "Обмен данными с МУ"
  • 3.
    Кнопки "Выгрузить" и "Загрузить" предназначены для выгрузки данных из ЦБД в МУ и загрузки данных в "Управление дистрибуцией" из МУ соответственно.
  • 4.
    Если флажок "Автообмен через Агент Плюс СОД" установлен, данные, поступившие из МУ в папку обмена, будут загружаться в "Управление дистрибуцией" автоматически.


Как настроить автообмен между УД и МУ?

Для того чтобы настроить автообмен следует выполнить следующие действия:
1. Перейти в справочник "Команды системы". Для перехода к справочнику необходимо в подсистеме "Обмен с мобильными устройствами" выбрать пункт "Служебные справочники" ( Рис. 3.3 ), а затем выбрать из списка справочник "Команды системы" ( Рис. 3.4 ).
Рис. 3.3. Подсистема "Обмена с мобильными устройствами",
Рис. 3.4. Окно "Служебные справочники настройки и обмена с МУ"
2. Создать новый элемент ( Рис. 3.4 ).
Рис. 3.5. Команды системы. Кнопка "Создать"
3. Не заполняя никаких полей, нажать кнопку "Создать команду из шаблона" ( Рис. 3.6 ).
Рис. 3.6 Создание элемента справочника "Команды системы"
4. В форме списка шаблонов команд системы нажать кнопку "Заполнить", в случае если поле "Текст команды" не заполнено или если список шаблонов пуст ( Рис. 3.7 ).
Рис. 3.7. Заполнение справочника "Шаблоны команд системы".
5. После чего выбрать предопределенную команду "Отправка данных через службу "Агент Плюс СОД"" ( Рис. 3.8 );
Рис. 3.8. Справочник "Шаблоны команд системы". Команда "Отправка данных через службу "Агент Плюс СОД""
6. После чего следует установить флажок "Использовать расписание" и настроить расписание, нажав на ссылку "Настроить расписание регламентного задания" ( Рис. 3.9 ).
Рис. 3.9. Команда системы. Флажок "Использовать расписание"
Аналогично создается команда системы для загрузки при помощи шаблона команд системы "Прием данных через службу "Агент Плюс СОД"".
Со стороны МУ следует задать расписание автообмена в разделе "Настройки обмена" (подробнее см. документ "Руководство по установке и настройке МТ.Проф").


Как создать персональные настройки обмена для агента?

  • 1.
    Персональные настройки обмена задаются в подсистеме "Обмен с мобильными устройствами", раздел "Персональные настройки обмена с МУ" ( Рис. 3.10 ).
    Рис. 3.10. Подсистема "Обмен данными с МУ"
  • 2.
    Для создания новой настройки следует нажать кнопку "Создать" ( Рис. 3.11 ).
Как создать персональные настройки обмена для агента?
Рис. 3.11. Персональные настройки обмена с МУ
В окне создания персональной настройки заполнить две вкладки: "Основные настройки" и "Дополнительные настройки" ( Рис. 3.12 ).
Рис. 3.12. Окно "Персональная настройка обмена с МУ"
3. Заполнить данные об агенте ( Рис. 3.13 ). Подробнее см. во встроенной справке конфигурации .
Рис. 3.13. Окно "Персональные настройки обмена с МУ". Вкладка "Дополнительные настройки"
4. Для изменения настроек приложения "Мобильная торговля" на устройстве сотрудника необходимо в окне "Персональные настройки обмена с МУ" нажать на кнопку "Настройки приложения на устройстве" в верхней части окна ( Рис. 3.14 ).
Рис. 3.14. Кнопка "Настройки приложения на устройстве"
5. Откроется окно настроек мобильного приложения на устройстве. Настройки могут быть заполнены значениями по умолчанию или с использованием шаблонов настроек приложения на МУ (кнопка "Заполнить") ( Рис. 3.15 ). Подробнее описание настроек смотри во встроенной справке конфигурации.
Рис. 3.15. Окно "Настройка мобильного приложения на устройстве агента"


Как настроить работу карт?

Список скриптов онлайн карт, которые будут использоваться в мобильных устройствах агентов, задается в справочнике "Оналйн-карты" в "Управление дистрибуцией".
Для перехода к справочнику необходимо в подсистеме "Нормативно-справочная информация" выбрать пункт "Настройки и справочники – Онлайн-карты".
Как настроить работу карт?
Рис. 3.19. Окно "Настройка мобильного приложения на устройстве агента"
Справочник можно заполнить автоматически из формы списка (кнопка "Загрузить примеры скриптов") или вручную.
При нажатии на кнопку "Загрузить примеры скриптов" открывается окно "Загрузка примеров скриптов онлайн-карт", в котором следует указать путь к каталогу с примерами скриптов ( Рис. 3.20 ).
Рис. 3.20. Окно "Загрузка примеров скриптов онлайн-карт"
Чтобы загрузить файл скриптов в информационную базу из внешнего файла, необходимо создать новый элемент справочника "Онлайн-карты" и в окне элемента нажать на кнопку "Загрузить из файла".
Рис. 3.21. Окно элемента справочника "Онлайн-карты"
В результате откроется стандартное окно выбора файла. Для загруженного файла скриптов следует указать наименование и назначение.
Для того чтобы в МУ при просмотре маршрута агента по умолчанию использовалась определенная онлайн-карта, необходимо сделать онлайн-карту основной. Назначить основную онлайн-карту для мобильного устройства можно двумя способами:
  • •
    В списке элементов справочника "Онлайн-карты" выделить нужную онлайн карту с назначением "Для мобильных устройств" и нажать на кнопку "Сделать карту основной".
  • •
    В разделе "Общие настройки обмена данными с мобильными устройствами" на закладке "Треки перемещений и онлайн-карты" в поле "Основная онлайн-карта для мобильного устройства" выбрать карту с назначением "Для мобильных устройств".
Основная онлайн-карта для МУ будет обозначена иконкой [image].


  • 4. Общие настройки конфигурации

4. Общие настройки конфигурации


Как включить/отключить использование контрагентов?

Для того чтобы отключить использование в документах контрагентов необходимо в подсистеме "Администрирование" выбрать пункт "Настройка дистрибуции" и установить или снять флажок для настройки "Использовать контрагентов" ( Рис. 4.1 ).
Рис. 4.1. Окно "Настройка дистрибуции". Настройка "Использовать контрагентов"
После этого поле "Контрагент" исчезнет из оперативных документов и отчетов в "Управление дистрибуцией".


Как установить основную валюту учета?

Основная валюта учета денежных средств указывается в разделе "Настройка дистрибуции" в настройка "Валюта учета" ( Рис. 4.2 ). Значение указывается из справочника "Валюты".
Необходимые для работы валюты можно подобрать из "Общероссийского классификатора валют" – ОКВ (рекомендуется) или добавить вручную.
Значение настройки указывается в подсистеме "Администрирование", раздел "Настройка дистрибуции".
Основная валюта учета устанавливается автоматически после первоначального обмена с основной учетной системой предприятия
Рис. 4.2. Окно "Настройка дистрибуции". Настройка "Основная валюта учета"


Как включить использование характеристик и упаковок номенклатуры?

Список характеристик, по которым в программе можно вести дополнительный количественный учет номенклатуры, ведется в справочнике "Характеристики номенклатуры". Справочник доступен только при включенной настройке "Использовать характеристики номенклатуры".
Значение настройки указывается в подсистеме "Администрирование", пункт "Настройка дистрибуции" ( Рис. 4.3 ).
Рис. 4.3. Окно "Настройка дистрибуции". Настройки "Использовать характеристик" и "Использовать упаковки номенклатуры"
Использование упаковок номенклатуры регулируется настройкой "Использовать упаковки номенклатуры". Упаковки номенклатуры – это альтернативная единица измерения товара, для которой задается коэффициент пересчета по отношению к базовой единице измерения номенклатуры. При отключении настройки справочник "Упаковки номенклатуры" становится недоступным.


Как включить режим "Торговля с колес"?

Для создания в "Управление дистрибуцией" и на МУ документов "Перемещение", "Реализация" и "Поступление" необходимо включить режим "Торговля с колес".
Примечание.
Торговля с колес или Вэнселлинг ("van selling", ванселинг, вэн-селлинг) – это разновидность мелкооптовой торговли, практикуемая дистрибьюторскими компаниями при обслуживании дилерской сети, при которой торговый представитель осуществляет доставку и отгрузку товаров с оформлением сделки в учетной системе фирмы непосредственно в точке продажи.
В "Управление дистрибуцией" настройка включается в подсистеме "Администрирование", раздел "Настройка дистрибуции" ( Рис. 4.4 ).
Рис. 4.4. Окно "Настройка дистрибуции". Настройка "Использовать режим "Торговля с колес""
При установленном флажке для настройки "использовать режим "Торговля с колес"" в "Управление дистрибуцией" в подсистеме "Оперативные документы" становится доступным журнал документов "Перемещение".
Для включения "торговли с колес" на МУ следует открыть окно "Настройка мобильного приложения на устройстве" ( Рис. 4.5 ). Чтобы открыть окно "Настройка мобильного приложения на устройстве", необходимо в окне "Персональные настройки обмена с МУ" нажать на кнопку "Настройки приложения на устройстве" в верхней части окна .
Рис. 4.5. Окно "Настройка мобильного приложения на устройстве для агента"
Если для настройки "Торговля с колес" установлено значение "Нет", документ "Реализация" в МУ будет доступен только для просмотра, документы "Перемещение" и "Поступление" будут недоступны на МУ.


Как указать разные склады для товаров в документах продаж?

Указать товар с разных складов в документах продаж возможно при использовании многоскладского режима.
  • 1.
    Для того чтобы в табличной части документов продаж в "Управление дистрибуцией" отображалась колонка "Склад" (Рис.), необходимо установить флажок для настройки "Использовать склады в табличной части документов продажи" ( Рис. 4.6 ).
Рис. 4.6. Окно "Настройка дистрибуции". Настройка "Использовать склады в табличной части документов продаж"
После этого в табличной части документов продаж будет отображаться колонка "Склад", в которой можно распределять номенклатуру с разных складов ( Рис. 4.7 ).
Рис. 4.7. Табличная часть документа
2. Для включения многоскладского учета на МУ агента следует открыть окно "Персональные настройки обмена с МУ" и установить флажок "Использовать склады в табличной части документов продажи" ( Рис. 4.8 ).
Рис. 4.8. персональные настройки обмена с МУ. Вкладка "Дополнительные настройки"
После этого на МУ в приложении "Мобильная торговля.Проф" при подборе товара станет доступен выбор товара с разных складов в окне подбора количества ( Рис. 4.9 ).
Рис. 4.9. Окно подбора количества в приложении на МУ


Как установить скидку в документах вручную?

Отображение и установку ручных скидок для каждой отдельной позиции в документах продаж и в документах поступлений регулируют настройки "Использовать ручные скидки в продажах" и "Использовать ручные скидки в поступлениях" ( Рис. 4.10 ).
Рис. 4.10. Окно "Настройка дистрибуции". Настройки "Использовать ручные скидки в продажах" и "Использовать ручные скидки в поступлениях"
При включенных настройках в табличной части документов продаж появятся две колонки: "Сумма скидки" и "% ручной скидки". Указанная в колонке "% ручной скидки" скидка будет применена к номенклатуре в строке ( Рис. 4.11 ).
Рис. 4.11. Окно документа продаж. Закладка "Товары".
Скидка, применяемая ко всем позициям в документе, указывается на закладке "Дополнительно" в поле "Скидка (%)" ( Рис. 4.12 ).
Рис. 4.12. Окно документа продаж. Закладка "Дополнительно"
Использование скидок в документах на МУ регулируется настройкой "Разрешить изменять скидку" в разделе "Общие настройки документов" ( Рис. 4.13 ).
Рис. 4.13. Окно "Настройки мобильного приложения на устройстве для агента"


Как закрепить агента за супервайзером?

Перед закреплением агентов за супервайзером необходимо определить структуру предприятия и установить иерархическую связь подразделений в справочнике "Подразделения".
  • 1.
    Для того чтобы закрепить торгового агента за супервайзером, следует создать подчиненное подразделение ( Рис. 4.14 ).
    Как закрепить агента за супервайзером?
    Рис. 4.14. Справочник "Подразделения"
  • 2.
    Для подчиненного подразделения следует указать Руководителя. Руководителем должен быть указан супервайзер ( Рис. 4.15 ).
    Рис. 4.15. Элемент справочника "Подразделения". Вкладка "Главное"
  • 3.
    На вкладке "Сотрудники подразделения" указывается список сотрудников, закрепленных за данным подразделением. При помощи кнопки "Создать" можно создать нового агента и закрепить его за подразделением ( Рис. 4.16 ).
Рис. 4.16. Элемент справочника "Подразделения". Вкладка "Сотрудники подразделения"
Чтобы закрепить за подразделением созданного ранее агента, следует открыть карточку сотрудника в справочнике "Сотрудники", и в поле "Подразделение" указать требуемое значение ( Рис. 4.17 ).
Рис. 4.17. Карточка сотрудника
Для списка сотрудников, закрепленных за подразделением, будет установлено разграничение доступа по подразделению к объектам и данным в конфигурации.


Как ограничить доступ пользователей к определенным подсистемам и объектам конфигурации?

Для того чтобы ограничить права пользователя определенным образом, следует добавить пользователя в группу доступа, для которой установлены требуемые права и ограничения.
Группа доступа определяет совокупность действий с данными программы, которые могут выполнять участники этой группы. Как правило, группы доступа соответствуют различным должностным обязанностям (или видам деятельности) пользователей программы, например: администраторы, супервайзеры, торговые представители. Пользователь может входить одновременно в одну или несколько групп доступа, которые в совокупности образуют его персональные настройки прав доступа.
Закрепить пользователя за определенной группой доступа можно в справочнике "Группы доступа". Чтобы открыть справочник, необходимо в подсистеме "Администрирование" на панели навигации выбрать пункты "Настройки пользователей и прав – Группы доступа".
В окне элемента справочника "Группы доступа" указан профиль группы доступа. Именно в профиле группы доступа задаются права и ограничения для группы доступа. В Управление дистрибуцией предусмотрены 3 предопределенных профиля групп доступа: "Администратор", "Супервайзер" и "Агент (Торговый представитель)". Все ограничения для данных профилей установлены с учетом данных по подразделениям (RLS).
Подробнее о возможностях данных профилей групп доступа см. в документе "Руководство пользователя Управление дистрибуцией".
Как ограничить доступ пользователей к определенным подсистемам и объектам конфигурации?
Рис. 4.18. Элемент справочника "Группы доступа"


Как зарегистрировать учетную систему в Личном кабинете?

Регистрация учетной системы "Агент Плюс: Управление дистрибуцией в онлайн-сервисе "Агент Плюс: Личный кабинет" дает дополнительные возможности для выгрузки шаблонов настроек обмена на МУ агентов и сохранения настроек обмена в учетной системе, а также позволяет автоматически загружать обновления для "Управления дистрибуцией" и дает возможность использовать сервис "Карты" для просмотра данных о запланированных и фактических маршрутах агентов на карте онлайн.
Для регистрации учетной системы в Личном Кабинете следует открыть раздел "Администрирование – Настройка дистрибуции" и выбрать подраздел "Личный кабинет" ( Рис. 4.19 ).
Как зарегистрировать учетную систему в Личном кабинете?
Рис. 4.19. Настройка дистрибуции
При нажатии на гиперссылку "Регистрации в личном кабинете" откроется окно "Авторизация в Личном кабинете" ( Рис. 4.20 ).
Рис. 4.20. Окно регистрации учетной системы в Личном кабинете
В открывшемся окне следует указать логин и пароль учетной записи Личного кабинета. Если вы не зарегистрированы в Личном кабинете, то нажмите на ссылку "Перейти в "Личный кабинет"" и получите после регистрации данные для входа в Личный кабинет.
Для того чтобы зарегистрировать используемую учетную систему в своем личном кабинете, следует установить флажок "Регистрация учетной системы в ЛК", указать название учетной системы и нажать кнопку "Регистрация в Личном кабинете".


5. Последовательность действий пользователя "Управление дистрибуцией"

Для начала работы с Управление дистрибуцией необходимо:
  • •
    настроить обмен с основной учетной системой организации (раздел "Обмен данными между "Агент Плюс: Управление дистрибуцией" и учетной системой");
  • •
    настроить обмен между Управление дистрибуцией и мобильными устройствами агентов (раздел "Настройка обмена с МУ");
  • •
    указать координаты для всех торговых точек (раздел "Установка координат торговой точки из карточки торговой точки" для задания координат для одной торговой точки, раздел "Установка координат при помощи обработки "Установка координат"" как для одиночной, так и для групповой установки координат);
  • •
    задать план продаж для агентов (раздел "Планы продаж");
  • •
    задать план посещений для агентов (раздел "Планы посещений") на основании плана продаж или как самостоятельный документ;
  • •
    назначить агентам документы "Задания агенту" вручную или создать автоматически при помощи шаблонов в "Плане посещений";
  • •
    на основании полученных от агентов данных сформировать отчеты.
См. также:
  • •
    Планы продаж
  • •
    Планы посещений
  • •
    Задания агенту


Торговые точки

Точки, в которые осуществляется продажа товара (например, магазины, отделы продаж, торговые места на рынках, павильоны и т.д.), заносятся в справочник "Торговые точки" ( Рис. 5.1 ). Для перехода к справочнику необходимо в подсистеме "Нормативно-справочная информация" выбрать пункт "Торговые точки".
Элементы справочника "Торговые точки" могут быть получены из основной учетной системы организации, загружены от дистрибьютора (при помощи обработки "Сопоставление данных из XML") или созданы непосредственно в "Управление дистрибуцией".
Для торговой точки следует задать связь с агентом ( [image]) и подразделением ( [image]). Связь с подразделением влияет на доступность торговых точек пользователю при включенной функциональной опции "Ограничить доступ по подразделениям (RLS)" в карточке пользователя. Связь с агентом влияет на автоматическое заполнение документа "План посещений" (при заполнении поля "Агент" в окне параметров заполнения табличной части (ссылка на Рис.)) и на выгрузку торговых точек на МУ агента при использовании режима "По агенту" (см. раздел "Как выгрузить торговые точки на МУ агента?").
Для торговой точки также следует задать координаты ( [image]). Если в поле "Адрес торговой точки" ( [image]) указан корректный адрес, то координаты могут быть определены по адресу точки (см. раздел "Как задать координаты для торговой точки?").
Рис. 5.1. Карточка торговой точки


Как выгрузить торговые точки на МУ агента?

Общие настройки для выгрузки торговых точек для всех агентов задаются в разделе "Общие настройки обмена данными с МУ".
  • 1.
    Для того чтобы открыть окно настроек в подсистеме "Обмен данными с мобильными устройствами" следует выбрать раздел "Общие настройки обмена с МУ" ( Рис. 5.2 ).
    Рис. 5.2. Подсистема "Обмен данными с МУ"
  • 2.
    На закладке "Выгрузка данных (справочники)" следует установить флажок "Выгружать торговые точки" ( Рис. 5.3 ).
    Рис. 5.3. Общие настройки обмена данными с МУ. Вкладка "Выгрузка данных (справочники)"
  • 3.
    В поле "Режим выгрузки" необходимо выбрать режим выгрузки справочника "Торговые точки":
  • a.
    Из плана посещений – на МУ агентов будут выгружаться торговые точки, включенные в документ "План посещений".
  • b.
    По подразделению агента – на МУ агентов будут выгружаться торговые точки, закрепленные за подразделением, к которому принадлежит агент.
  • c.
    По агенту – на МУ агентов будут выгружаться торговые точки, закрепленные за агентом (поле "Агент" в карточке торговой точки ( Рис. 5.1 )).
  • d.
    Все – на МУ агентов будет выгружаться весь справочник "Торговые точки".
Индивидуальный отбор для выгрузки торговых точек задается в разделе "Персональные настройки обмена с МУ" на закладке "Дополнительные настройки" ( Рис. 5.4 ).
Рис. 5.4. Окно "Персональная настройка обмена с МУ". Вкладка "Дополнительные настройки"


Как задать координаты для торговой точки?

Задать координаты для торговой точки можно из карточки торговой точки или при помощи обработки "Установка координат торговых точек".
Примечание.
Для просмотра сведений о координатах торговой точки должно быть установлено Интернет-соединение.


Установка координат торговой точки из карточки торговой точки

Для того чтобы установить координаты из карточки торговой точки, следует:
  • 1.
    открыть карточку нужной торговой точки ( Рис. 5.5 ) и в поле координаты нажать на кнопку [image];
    Рис. 5.5. Документ "Возврат от дистрибьютора"
  • 2.
    в открывшемся окне "Координаты" координаты могут быть заданы двумя способами:
    a. Если в карточке торговой точки был указан адрес, то местоположение может быть определено автоматически по нажатию на кнопку "Определить координаты по адресу" ( Рис. 5.6 ).
Рис. 5.6. Окно "Координаты". Кнопка "Определить координаты по адресу"
Если для указанного адреса есть близкие соответствия в черте выбранного населенного пункта, то появится диалоговое окно, в котором необходимо уточнить адрес ( Рис. 5.7 ):
Рис. 5.7. Окно выбора адреса
b. Если адрес для торговой точки не указан, то местоположение может быть указано на карте вручную ( Рис. 5.8 ).
Рис. 5.8. Окно "Координаты". Кнопка "Указать местоположение на карте"
После нажатия откроется обработка "Выбор места на карте". Для указания координат следует отметить левой кнопкой мыши выбранное место на карте и нажать на кнопку "Записать" ( Рис. 5.9 ).
Рис. 5.9. Окно обработки "Выбор места на карте"
Окно обработки закроется, во вновь открывшемся окне "Координаты" следует нажать на кнопку "ОК" для сохранения координат. В карточке торговой точки следует нажать на кнопку "Записать" или "Записать и закрыть".


Установка координат при помощи обработки "Установка координат"

  • 1.
    Для вызова обработки необходимо открыть справочник Торговые точки и нажать на кнопку "Установка координат" ( Рис. 5.10 ).
    Установка координат при помощи обработки "Установка координат"
    Рис. 5.10. Справочник "Торговые точки". Кнопка "Установка координат"
  • 2.
    В открывшемся окне обработки следует заполнить список торговых точек, для которых следует установить координаты ( Рис. 5.11 ). Возможно использование следующих способов:
Рис. 5.11. Обработка "Установка координат торговых точек". Кнопка подбора торговых точек.
  • a.
    По подразделению. В табличную часть будут добавлены торговые точки, закрепленные за выбранным подразделением. Значение выбирается из справочника "Подразделения".
  • b.
    По торговым точкам. В табличную часть будут добавлены торговые точки, выбранные из справочника "Торговые точки".
  • c.
    По списку торговых точек. В табличную часть будут добавлены торговые точки, включенные в выбранный список торговых точек. Значение выбирается из справочника "Списки торговых точек".
3. В появившемся списке торговых точек точки, для которых координаты не указаны, будут выделены красным цветом и напротив их наименований будут установлены флажки ( Рис. 5.12 ).
Рис. 5.12. Обработка "Установка координат торговых точек".
Координаты для точек могут быть указаны следующими способами:
  • a.
    автоматически по адресу – для точек с указанным адресом местоположение будет определено автоматически. Для этого следует нажать на кнопку "Определить по адресу". Для торговых точек будут заданы координаты, соответствующие адресу. Несохраненные значения координат будут выделены красным цветом. Чтобы сохранить изменения, следует нажать кнопку "Сохранить координаты".
  • b.
    с помощью карты – для указания координат расположения торговой на карте необходимо установить флажок напротив наименования торговой точки в списке слева и "мышью" отметить точку на карте. Несохраненные значения координат будут выделены красным цветом. Чтобы сохранить изменения, следует нажать кнопку "Сохранить координаты".


Как указать связь нескольких торговых точек с одним контрагентом?

Справочник торговые точки является иерархическим, и в нем можно создать сесть торговых точек, закрепленных за одним контрагентом.
Например, существует сесть торговых точек, принадлежащих "ИП Иванов И.И.". Документы заказа товаров формируются для каждой торговой точки отдельно, но документы реализации и кассовые ордера оформляются на "ИП Иванов И.И.". Для того чтобы правильно установить связь между торговыми точками и контрагентом, потребуется сделать следующее:
  • 1.
    В справочнике "Торговые точки" создать Основную торговую точку сети и внутри неё создать подчиненные торговые точки, которые и являются фактическими торговыми точками, от имени которых оформляются документы Заказ.
    Для того чтобы создать торговую точку, входящую в иерархию, следует включить режим просмотра справочника "Иерархический список" (меню "Еще – Режим просмотра – Иерархический список"), выделить нажатием основную торговую точку иерархии и нажать кнопку "Создать".
    Как указать связь нескольких торговых точек с одним контрагентом?
    Рис. 5.13. Иерархия справочника "Торговые точки".
  • 2.
    Для основной торговой точки иерархии следует задать связь с контрагентом "ИП Иванов И.И.".
    Рис. 5.14. Закрепление контрагента за Основной торговой точкой.
  • 3.
    Для подчиненных торговых точек иерархии следует также указать связь с контрагентом. Для этого следует для каждой торговой точки иерархии указать контрагента "ИП Иванов И.И.", установив флаг "Включая контрагентов точек-родителей".
    Рис. 5.15. Карточка подчиненной торговой точки иерархии. Закладка "Контрагенты".
  • 4.
    Таким образом созданные торговые точки будут объединены в общую сеть. Для каждой торговой точки может быть указан индивидуальный договор или использоваться договор Основной торговой точки. Договор Основной торговой точки отобразится в списке при установке флажка "Включая договора точек-родителей").
Рис. 5.16. Карточка подчиненной торговой точки иерархии. Закладка "Договоры".


Планы продаж

Для постановки планов по продажам товаров подразделениям или торговым агентам на заданный период используются документы "План продаж". Для одного подразделения или торгового агента может быть сформировано несколько планов продаж на один и тот же период.
См. также:
  • •
    Как создать план продаж?
  • •
    Как выгрузить план продаж на МУ агента?
  • •
    Как созданный план продаж будет отображаться на МУ агента?


Как создать план продаж?

Для того чтобы создать документ "План продаж" следует в подсистеме "Планирование и контроль" выбрать пункт "Планы продаж", и в журнале документов "Планы продаж" нажать на кнопку "Создать" ( Рис. 5.13 ).
Рассмотрим в качестве примера создание плана продаж на группу агентов по торговым точкам с детализацией товара по номенклатуре.
Как создать план продаж?
Рис. 5.13 Панель кнопок журнала документов "Планы продаж"
В открывшемся окне необходимо выполнить следующие действия ( Рис. 5.14 ):
  • 1.
    Указать вид плана одним из следующих способов:
  • a.
    выбрать из выпадающего списка – в выпадающем списке отображаются последние используемые элементы справочника "Виды планов продаж";
  • b.
    нажать на кнопку "Показать всё" – открывает окно справочника "Виды планов продаж" с полным списком его элементов;
  • c.
    создать новый вид плана продаж – при нажатии на кнопку [image] открывается окно создания вида плана продаж.
Рис. 5.14 Выбор вида плана продаж
При создании в виде плана продаж можно настроить следующие показатели:
  • •
    показатель планирования;
  • •
    детализацию продавцов;
  • •
    детализацию покупателей;
  • •
    детализацию товаров;
  • •
    периодичность.
    После этого необходимо заполнить табличную часть документа.
    Закладки табличной части зависят от вида связи продавец/покупатель/товар (подробнее о связях см. в документе "Руководство пользователя "Агент Плюс: Управление дистрибуцией"").
    2. Указать период действия плана продаж, статус и подразделение.
Примечание.
План продаж будет действовать и выгружаться на МУ агентов на протяжении заданного периода только при установленном статусе "Утвержден".
3. Указать агента.
В качестве продавцов в плане продаж с выбранной детализацией указываются агенты.
Добавить агента в документ можно двумя способами:
  • •
    при помощи кнопки "Добавить" ( [image]) ( Рис. 5.15 ). Сперва необходимо указать подразделение ( [image]), а затем выбрать агента из списка ( [image]).
Рис. 5.15 Заполнение списка агентов (по кнопке "Добавить")
  • •
    при помощи кнопки "Подбор продавцов" ( Рис. 5.16 ). При выборе агента из справочника "Сотрудники", поле "Подразделение" заполняется автоматически.
Рис. 5.16 Заполнение списка агентов (по кнопке "Подбор продавцов")
4. Добавить торговые точки в табличную часть документа.
Примечание.
Для добавления торговой точки в табличную часть документа следует выделить нажатием ЛКМ агента, после чего добавить торговую точку одним из описанных ниже способов.
Добавить торговую точку можно следующими способами:
  • •
    при помощи кнопки "Добавить" ( Рис. 5.17 ).
Рис. 5.17 Заполнение списка торговых точек (по кнопке "Выбрать")
  • •
    при помощи кнопки "Подбор покупателей" ( Рис. 5.18 ). Подбор покупателей может быть выполнен двумя способами:
  • 1.
    подбор покупателей открывает окно справочника "Торговые точки";
  • 2.
    подбор по списку торговых точек открывает окно справочника "Списки торговых точек".
Рис. 5.18 Заполнение списка торговых точек (по кнопке "Подбор покупателей")
5. Добавить список товаров к продаже.
Примечание.
Для добавления товара в табличную часть документа следует выделить нажатием ЛКМ агента и нужную торговую точку. После чего добавить товар одним из описанных ниже способов.
Добавить товар в табличную часть можно следующими способами ( Рис. 5.19 ):
  • •
    при помощи кнопки "Добавить" ( [image]) – выбирается единичное наименование номенклатуры в табличной части.
  • •
    при помощи кнопки "Подбор товаров" ( [image]) – выбор номенклатуры производится из открывшегося окна справочника "Номенклатура".
  • •
    при помощи кнопки "Добавить ассортимент" ( [image]) – выбирается определенный ассортимент товаров из списка элементов справочника "Ассортименты товаров".
Рис. 5.19 Указание торговой точки (по кнопке "Подбор покупателей")


Как создать план продаж на основании другого плана продаж?

План продаж может быть создан на основании другого плана при условии, что план, выступающий в качестве основания находится на уровень выше в иерархии планов продаж ().
Например, как показано на Рис. 5.20 .
Рис. 5.20. Иерархия справочника "Виды планов продаж"
Между планом-основанием и создаваемым планом производится проверка значений табличных частей, при этом для плана-основания должен быть установлен статус "На утверждении" или "Утвержден".
В случае если в создаваемом плане значения колонок не входят в список значений плана-основания, то документ не будет проведен.


Как выгрузить план продаж на МУ агента?

Для того чтобы созданный план продаж выгрузился при обмене данными на МУ торговым агентам, указанным в документе, необходимо включить настройку "Использовать планы продаж".
Включение настройки производится в подсистеме "Обмен с мобильными устройствами", раздел "Общие настройки обмена с МУ" ( Рис. 5.21 ).
Как выгрузить план продаж на МУ агента?
5.21 Подсистема "Обмен с мобильными устройствами"
Настройка находится в разделе "Выгрузка данных (документы)". При установленном флажке планы продаж будут выгружаться в МУ агентов ( Рис. 5.22 ).
Рис. 5.22 Общие настройки обмена данными. Выгрузка данных (документы)


Как созданный план продаж будет отображаться на МУ агента?

На МУ ход выполнения плана продаж будет отображаться в колонке "План продаж" ( [image]) в справочнике "Номенклатура", при подборе товаров в документ "Заказ".
5.23 План продаж в ПП "Агент Плюс: Мобильная торговля"
В колонке отображается процент или количество продаж согласно плана продаж. Значение колонки устанавливается в ЦБД. Величина процента/количество продаж считается относительно количества товара, указанного в плане продаж для торгового агента. В случае, если план продаж отображается в процентах, то в колонке будет указываться числовое значение выполнения плана продаж в процентах. Если выбрано количественное отображение плана продаж, то в колонке будет отображаться количество товара, которое необходимо продать (со знаком "–"), или количество, на которое план был перевыполнен (со знаком "+") ( Рис. 5.23 ).
Дополнительно информация в колонке выделяется цветом в зависимости от степени выполнения плана: менее 50% – текст ячейки выделяется красным; 50-99% – выделение текста отсутствует; 100% или более – цвет текста зеленый
Колонка отображается, если в мобильном приложении используются планы продаж товаров с детализацией по номенклатуре. Детализация по номенклатуре устанавливается в ЦБД.


Как контролировать выполнение плана продаж?

Для просмотра и анализа плановых и фактических данных по продажам товаров, а также процентов исполнения этого плана предназначен отчет "Выполнение плана продаж". Отчет может быть открыт из списка отчетов (подсистема "Планирование и контроль") ( Рис. 5.24 ) или из документа "План продаж" (ссылка "Отчет о выполнении" на панели навигации документа).
5.24 Подсистема "Планирование и контроль"
5.25 Отчет "Выполнение плана продаж"
Фактические показатели в отчете могут рассчитываться по документам "Реализация товаров и услуг" (с учетом документов "Возвраты товаров") или "Заказ клиента", в зависимости от показателя планирования, указанного в виде плана продаж.
При необходимости данные отчета могут быть распечатаны по кнопке "Печать".


Планы посещений

Документ "План посещений" предназначен для указания порядка посещения торговых точек (маршрута). План задается на определенный период: месяц, неделя, 2 недели или произвольный период. Данные из документа "План посещений" выгружаются в МУ в справочник "Клиенты и маршруты" и отображаются на закладке "Маршруты".
В "Управление дистрибуцией" могут быть созданы циклические (повторяющиеся планы посещений) и обычные не циклические планы посещений.
Примечание.
На один день нельзя ввести одновременно два и более обычных (не циклических) плана или два и более циклических. В этом случае программа выдаст предупреждение и не даст провести документ. Если требуется временно скорректировать циклический план посещений на определенный период, то для этого создается обычный план посещений. Обычный план посещений вытеснит циклический и будет выгружен на МУ агента. По окончании периода действия обычного плана в МУ снова начнет выгружаться циклический план посещений.
См. также:
  • •
    Как создать план посещений?
  • •
    Как оптимизировать маршрут агента?


Как создать план посещений?

Документ "План посещений" может быть создан несколькими способами:
  • 1.
    Вручную. Для того в подсистеме "Планирование и контроль" следует выбрать пункт "Планы посещений" и в журнале документов "Планы посещений" нажать на кнопку "Создать" ( Рис. 5.26 ).
    5.26 Панель кнопок журнала документов "Планы посещений"
    При создании документа "План посещений" вручную табличная часть может быть заполнена несколькими способами ( Рис. 5.27 ):
    5.27 Панель кнопок журнала документов "Планы посещений"
  • a.
    при помощи кнопки "Добавить" ( [image]) указать единичную торговую точку из списка торговых точек, закрепленных за агентом (связь агента и торговой точки закрепляется в карточке торговой точки);
  • b.
    при помощи кнопки "Подбор" ( [image]) указать одну или несколько торговых точек из списка торговых точек, закрепленных за агентом;
  • c.
    при помощи кнопки "Заполнить" ( [image]). При этом откроется окно, в котором следует указать параметры заполнения табличной части ( Рис. 5.28 ).
5.28 Окно "Параметры заполнения плана посещений"
2. Автоматически на основании документа "План продаж", который имеет детализацию продавцов "по агенту", детализацию покупателей "по торговым точкам" (данные параметры настраиваются в виде плана продаж) ( Рис. 5.29 ).
Как создать план посещений?
5.29 Создание документа "План посещений" на основании плана продаж
Примечание.
Документ "План продаж", на основании которого создается план посещений, должен иметь статус "На утверждении" или "Утвержден".
Если в плане продаж имеется несколько агентов, то система запросит в диалоговом окне указать агента для планирования посещений ( Рис. 5.30 ).
5.30 Выбор агента для планирования посещений
После выбора агента, для которого будет создан план посещений, табличная часть документа будет заполнена торговыми точками из плана продаж.
Примечание.
Для того чтобы план посещений автоматически распределял график визитов для торговой точки, необходимо указать в карточке торговой точки график посещений на вкладке "Планирование" ( Рис. 5.31 ).
5.31 Карточка торговой точки. Вкладка "Планирование"
Примечание.
Для того чтобы план посещений был доступен на мобильном устройстве агента, необходимо перевести документ в статус "Утвержден". Документ будет доступен на мобильном устройстве с даты начала планирования.


Как оптимизировать маршрут агента?

При планировании маршрута порядок посещения торговых точек может быть оптимизирован с учетом расстояния между точками.
Для того чтобы оптимизировать маршрут, следует включить настройку "Использовать порядок".
После этого в контекстном меню для маршрута на конкретный день станут доступны пункты меню ( Рис. 5.32 ):
  • •
    Оптимизировать маршрут. Устанавливает оптимальный порядок следования торговых точек в маршруте на определенный день с учетом расстояния между ними. Алгоритм, по которому выполняется оптимизация маршрута, задается в настройке "Алгоритм оптимизации маршрутов" в разделе "Администрирование – Настройка дистрибуции". После выполнения оптимизации маршрута необходимо выполнить пересчет итоговой длины маршрута.
  • •
    Оптимизировать все маршруты. Устанавливает оптимальный порядок следования торговых точек в маршруте на все дни посещений в рамках документа "План посещений".
  • •
    Пересчитать итоги маршрутов. Рассчитывает суммарную длину всех маршрутов в документе "План посещений". При выполнении оптимизации сразу всех маршрутов в плане пересчет итоговой длины маршрута выполняется автоматически.
Как оптимизировать маршрут агента?
5.32 План посещений. Контекстное меню.
Для того чтобы оптимизировать маршрут посещений торговой точки автоматически, следует выбрать пункт контекстного меню "Оптимизировать маршрут" или "Оптимизировать все маршруты".
Оптимизация маршрута производится согласно заданным значениям начальной и конечной точек маршрута, значения которых задаются в разделе "Администрирование – Настройка дистрибуции" или на закладке "Прочее" непосредственно в документе "План посещений" ( Рис. 5.33 ). В зависимости от выбранного варианта начальной и конечной точек может быть создан кольцевой или разомкнутый маршрут.
5.33 План посещений. Закладка "Прочее"
Для редактирования порядка торговых точек на карте следует выделить нужный день посещения, вызвать контекстное меню нажатием правой кнопки мыши и выбрать пункт контекстного меню "Показать на карте". Откроется окно "Редактор маршрута", в котором будет отображен маршрут на выбранный день.
5.34 Редактор маршрута. Отображение маршрута на карте.
В редакторе маршрута можно не только просмотреть, но и отредактировать порядок посещения торговых точек. Порядок посещения торговых точек изменяется при помощи пунктов меню "Переместить вверх" и "Переместить вниз", доступных из меню "Еще" или при вызове контекстного меню для точки из списка маршрута ( Рис. 5.34 ).
Для того чтобы автоматически рассчитать и построить оптимальный маршрут, необходимо нажать на кнопку "Оптимальный маршрут". Торговые точки в списке будут выстроены в оптимальной последовательности посещения и маршрут агента построится в соответствии с заданными значениями начальной и конечной точек маршрута.
Для отображения маршрута по дорогам ( Рис. 5.34 ) необходимо нажать на кнопку "Еще" и выбрать пункт меню "Маршрут по дорогам".


Как создать документы "Задание агенту" при формировании плана посещений?

При создании плана посещений можно запланировать выполнение ряда задач по общему шаблону для каждого из посещений.
Для этого необходимо установить флажок для настройки "Использовать шаблоны заданий в планах посещений" ( [image]) в разделе "Общие настройки обмена данными с МУ", подраздел "Выгрузка данных (документы)" ( Рис. 5.35 ).
Рис. 5.35. Общие настройки обмена данными с МУ. Вкладка "Выгрузка данных (документы)"
При установленном флажке для данной настройки в плане посещений на закладке "Прочее" становится доступным поле "Шаблон заданий" ( Рис. 5.36 ). В поле указывается шаблон заданий, который будет применен для запланированных посещений в документе "План посещений". Значение выбирается из справочника "Шаблоны заданий". При выгрузке в мобильное устройство агента для торговых точек, включенных в маршрут, будут созданы документы "Задание" по выбранному в данном поле шаблону.
Как создать документы "Задание агенту" при формировании плана посещений?
Рис. 5.36. Документ "План посещений". Закладка "Прочее". Поле "Шаблон заданий"
Если шаблон заданий не выбран, то задания по данному плану пощений не будут созданы.
Возможен выбор группы шаблонов – каждый шаблон группы в этом случае привязывается к категории торговой точки, т.е. для каждой посещаемой торговой точки будет использован шаблон заданий, соответствующий категории этой точки. Если в выбранной группе есть шаблон, не закрепленный ни за одной конкретной категорией торговых точек, то такой шаблон используется для торговых точек с категорией, для которой отсутствует шаблон заданий в выбранной группе шаблонов.
Примечание.
Автоматически сгенерированные документы "Задание" создаются только при выгрузке данных в файле обмена данными "FromCDB.xml". В журнале документов "Задание агенту" такие документы не сохраняются. Интервал выгрузки заданий на предыдущие и следующие дни регулируется константами "Интервал выгрузки заданий агентам за последние ... дней" и "Интервал выгрузки заданий агентам на следующие ... дней" в разделе "Общие настройки обмена данными с МУ" подраздел "Выгрузка данных (документы)" ( Рис. 5.35 ).


Как выгрузить план посещений на МУ агента?

Данные из документа "План посещений" выгружаются в МУ в справочник "Клиенты и маршруты" и отображаются на закладке "Маршруты". На отображение данной закладки и порядок работы с посещениями по маршруту влияют настройки группы "Маршруты" в разделе "Настройки мобильного приложения на устройстве" ( Рис. 5.37 ). Чтобы открыть окно "Настройка мобильного приложения на устройстве", необходимо в окне "Персональные настройки обмена с МУ" нажать на кнопку "Настройки приложения на устройстве" в верхней части окна.
Для того чтобы закладка "Маршруты" отображалась на устройстве агента, для настройки "Использовать маршруты" следует установить значение "Да".
Рис. 5.37 Настройка мобильного приложения на устройстве. Группа настроек "Маршруты"
Маршруты могут быть выгружены на МУ на несколько дней вперед. Количество дней зависит от значения указанного в настройке "Интервал выгрузки маршрутов на следующие ... дней" в разделе "Общие настройки обмена данными с МУ – Выгрузка данных (документы)" ( Рис. 5.38 ).
Примечание.
Если в значении настройки установлено "0", то маршруты выгружаться на МУ не будут.
Как выгрузить план посещений на МУ агента?
Рис. 5.38 Общие настройки обмена данными. Выгрузка данных (документы)
Выгруженный маршрут на текущий день отобразится в МУ на закладке "Маршруты" ( Рис. 5.39 ).
Рис. 5.39. Маршрут в ПП "Агент Плюс: Мобильная торговля"


Как контролировать выполнение плана посещений?

Для просмотра и анализа данных о количестве выполненных торговым агентом посещений, а также о соотношении запланированных посещений и посещений, выполненных вне плана, предназначен отчет "Выполнение плана посещений агентом". Отчет может быть открыт из списка отчетов (подсистема "Планирование и контроль") ( Рис. 5.40 ).
Рис. 5.40. Подсистема "Планирование и контроль".
Как контролировать выполнение плана посещений?
Рис. 5.41.Отчет "Выполнение плана посещений агентом"
В табличной части отображается список торговых точек, указанных в плане посещений для указанного торгового агента, по документам которого строится отчет, и график посещений, детализированный по дням. Для формирования отчета также используется значение настройки "Максимальное удаление от клиента, м". Если значение настройки не указано, то при формировании отчета используется значение "50 м.".
При необходимости данные отчета могут быть распечатаны по кнопке "Печать".


Задания агенту

Документ "Задание агенту" предназначен для постановки сотруднику списка задач, которые ему необходимо выполнить в течение дня. Например, создание какого-либо документа, создание фотографии, обмен данными и т.п.
См. также:
  • •
    Как создать задание агенту?


Как создать задание агенту?

Документ "Задание агенту" может быть создан несколькими способами:
1. Создать автоматически по шаблону.
Для этого необходимо в разделе "Общие настройки обмена с МУ – Выгрузка данных (документы)" включить настройку "Использовать шаблоны заданий в планах посещений" и установить интервал выгрузки заданий на предыдущие и следующие дни в константах "Интервал выгрузки заданий агентам за последние ... дней" и "Интервал выгрузки заданий агентам на следующие ... дней" ( Рис. 5.42 ).
Примечание.
Автоматически сгенерированные документы "Задание" создаются только при выгрузке данных в файле обмена данными "FromCDB.xml". В журнале документов "Задание агенту" такие документы не сохраняются.
Рис. 5.42 Общие настройки обмена данными. Выгрузка данных (документы)
После этого в документе "План посещений" на закладке "Прочее" появится поле "Шаблон заданий", в котором может быть выбран шаблон заданий или группа шаблонов.
Примечание.
Возможен выбор группы шаблонов – каждый шаблон группы в этом случае привязывается к категории торговой точки, т.е. для каждой посещаемой торговой точки будет использован шаблон заданий, соответствующий категории торговой точки. Если в выбранной группе есть шаблон, не закрепленный ни за одной конкретной категорией торговых точек, то такой шаблон используется для торговых точек с категориями, для которых отсутствуют шаблоны заданий в выбранной группе шаблонов.
2. Вручную. Для того в подсистеме "Оперативные документы" следует выбрать пункт "Задания агентам" и в журнале документов нажать на кнопку "Создать" ( Рис. 5.43 ).
Рис. 5.43. Панель кнопок журнала документов "Задания агентам"
Добавить задачи в табличную часть можно тремя способами ( Рис. 5.44 ):
  • 1.
    При помощи пункта "Заполнить всеми" ( [image]). При этом в табличную часть попадут все имеющиеся виды задач по группам.
  • 2.
    При помощи пункта "Заполнить по шаблону" ( [image]). При этом в табличную часть попадут виды задач, включенные в выбранный шаблон.
  • 3.
    При помощи подбора ( [image]) из справочника "Виды задач".
Как создать задание агенту?
Рис. 5.44. Документ "Задание агенту". Табличная часть "Задачи"
Обязательные к выполнению задачи следует отметить флажком в колонке "Обязательная".
Чтобы запретить возможность изменения заданий на МУ, следует установить флажок "Не изменять в МУ".
Примечание.
Возможность редактирования документов "Задание агенту" на МУ после завершения выполнения регулируется настройкой "Разрешить редактирование "Заданий" в разделе "Настройка мобильного приложения на устройстве для агента" ( Рис. 5.45 ).
Рис. 5.45. Окно "Настройка мобильного приложения на устройстве агента". Настройка "разрешить редактирование "Заданий""


Как создать задачу и шаблон заданий?

Для того чтобы поставить задачи в документе "Задание агенту", сперва следует заполнить справочник "Виды задач".
Для перехода к справочнику необходимо в подсистеме "Нормативно-справочная информация" выбрать пункт "Настройки и справочники", а затем выбрать подпункт "Виды задач" ( Рис. 5.46 ).
Рис. 5.46. Настройки и справочники
Для создания новой задачи следует нажать кнопку "Создать" в окне справочника.
Для нового вида задачи следует указать наименование и группу и выбрать тип задачи из предопределенного списка ( Рис. 5.47 ). Задачи схожего типа могут объединяться в группы для облегчения поиска.
Как создать задачу и шаблон заданий?
Рис. 5.47. Документ "Возврат от дистрибьютора"
Созданные задачи могут быть объединены в шаблоны в справочнике "Шаблоны заданий".
Для перехода к справочнику необходимо в подсистеме "Нормативно-справочная информация" выбрать пункт "Настройки и справочники", а затем выбрать подпункт "Шаблоны заданий" ( Рис. 5.48 ).
Для шаблона заданий необходимо указать список задач в табличной части элемента справочника. Значения выбираются из списка элементов справочника "Виды задач".
Рис. 5.48. Окно элемента справочника "Шаблоны заданий"


Как создать и отредактировать задание на МУ?

Возможность создания и редактирования документов "Задание" на МУ регулируется настройками "Разрешить создание "Заданий"" и "Разрешить редактирование "Заданий"" в разделе "Настройка мобильного приложения на устройстве агента". Чтобы открыть окно "Настройка мобильного приложения на устройстве", необходимо в окне "Персональные настройки обмена с МУ" нажать на кнопку "Настройки приложения на устройстве" в верхней части окна.
Как создать и отредактировать задание на МУ?
Рис. 5.49 Настройка мобильного приложения на устройстве. Группа настроек "Задание"
В случае если важен порядок выполнения задач на МУ, обязательность выполнения задач по порядку может быть закреплена при помощи настройки "Учитывать порядок выполнения задач".


Сообщения агентам

В мобильные устройства агентам можно выгружать сообщения и напоминания. При создании сообщения может быть указан список агентов, которым будет выгружено сообщение, расписание выгрузки и периодичность появления сообщений на МУ агента.
Рис. 5.50 Окно "Сообщения агентам"


Как выгрузить сообщения на МУ списку агентов?

Чтобы создать сообщение агенту необходимо в подсистеме "Планирование и контроль" выбрать пункт "Сообщения агентам" и нажать на кнопку "Создать" ( Рис. 5.51 ).
Как выгрузить сообщения на МУ списку агентов?
Рис. 5.51 Панель кнопок журнала документов "Задания агентам"
Для того чтобы сообщение выгрузилось на МУ следует заполнить следующую информацию ( Рис. 5.52 ):
  • 1.
    Указать тему сообщения;
  • 2.
    Указать текст сообщения;
  • 3.
    На закладке "Список агентов" указать будет ли выгружаться сообщение всем агентам или агентам по списку. В случае выгрузки по списку агентов следует заполнить список агентов в табличной части;
  • 4.
    На закладке "Расписание" указать дату выгрузки и периодичность напоминания;
  • 5.
    На закладке "Дополнительные настройки" указать при необходимости цвет текста, документ-основание (заполняется только если выбран один агент) и указать будет ли выводиться диалоговое окно с сообщением.
Рис. 5.52 Панель кнопок журнала документов "Задания агентам"


Посещение

В документе "Посещение" фиксируются результаты посещения торговой точки, например, причины нерезультативного посещения, также при помощи данного документа можно провести анкетирование клиента.
Документ "Посещение" оформляется торговым агентом во время визита в торговую точку и, в зависимости от результатов посещения, в документе может быть создано анкетирование.


Как провести анкетирование при посещении торговой точки?

В документе возможно проведение анкетирования, если выбран результат посещения, для которого установлен признак проведения анкетирования. Список возможных результатов задается в справочнике "Результаты посещения". Для перехода к справочнику необходимо в подсистеме "Нормативно-справочная информация" выбрать пункт "Настройки и справочники", а затем выбрать подпункт "Результаты посещений" ( Рис. 5.53 ).
Рис. 5.53. Документ "Возврат от дистрибьютора"
Для создания нового элемента справочника следует нажать кнопку "Создать". В открывшемся окне необходимо указать наименование и установить флажок "Используется для проведения анкетирования" ( Рис. 5.54 ).
При установленном флажке появится поле "Шаблон анкеты". Указанный в поле шаблон анкетирования (т.е. вопросы, включенные в шаблон) будет закреплен для проведения анкетирования за данным результатом посещения.
Рис. 5.54. Документ "Возврат от дистрибьютора"
См. также:
  • •
    Как создать шаблон анкеты?


Как создать вопрос для анкетирования?

Список вопросов для анкетирования создается и хранится в справочнике "Вопросы анкеты".
  • 1.
    Для перехода к справочнику необходимо в подсистеме "Нормативно-справочная информация" выбрать пункт "Настройки и справочники", а затем выбрать подпункт "Вопросы анкеты" ( Рис. 5.55 ).
    Рис. 5.55. Настройки и справочники. Пункт "Вопросы анкеты"
  • 2.
    Для создания нового шаблона анкеты следует нажать кнопку "Создать". В окне создания вопроса отображаются две закладки: "Главное" и "Ответы анкеты" ( Рис. 5.56 ).
    .
  • 3.
    На закладке "Главное" указывается следующая информация:
Рис. 5.56. Документ "Возврат от дистрибьютора"
  • •
    Код – код присваивается вопросу автоматически при записи, но может быть отредактирован вручную.
  • •
    Наименование – непосредственный текст вопроса.
  • •
    Тип ответа – определяет, в каком виде будет указываться ответ на вопрос.
  • •
    Выгружать в МУ – признак возможности выгрузки вопроса в МУ агента. Если флажок установлен, то вопрос будет выгружаться в МУ и может быть использован при создании документа "Посещение" агентом непосредственно на устройстве.
4. На закладке "Ответы анкеты" задается список ответов на вопрос анкеты. Для нового вопроса анкеты список ответов пустой.
5. Для того чтобы задать новый вариант ответа, следует нажать кнопку "Создать" на закладке "Ответы анкеты" ( Рис. 5.57 ).
.
Рис. 5.57. Документ "Возврат от дистрибьютора"
Список созданных ответов на вопросы анкеты фиксируется в справочнике "Ответы анкеты".
6. После добавления ответов следует нажать на кнопку "Записать" или "Записать и закрыть".


Как создать шаблон анкеты?

Вопросы, записанные в справочнике "Вопросы анкеты" могут быть объединены в шаблоны
  • 1.
    Для перехода к справочнику необходимо в подсистеме "Нормативно-справочная информация" выбрать пункт "Настройки и справочники", а затем выбрать подпункт "Шаблоны анкет" ( Рис. 5.58 ).
    Рис. 5.58. Настройки и справочники. Пункт "Шаблоны анкеты"
  • 2.
    Для создания нового шаблона анкеты следует нажать кнопку "Создать". В окне создания шаблона отображаются две закладки: "Главное" и "Вопросы шаблона" ( Рис. 5.59 ).
  • 3.
    На закладке "Главное" необходимо заполнить поле "Наименование" и записать изменения.
    Рис. 5.59. Окно элемента справочника "Шаблоны анкеты". Закладка "Главное"
  • 4.
    На закладке "Вопросы шаблона" указывается список вопросов для анкетирования. Для добавления вопроса в список следует нажать кнопку "Создать" ( Рис. 5.60 ).
    Рис. 5.60. Документ "Возврат от дистрибьютора"
  • 5.
    Откроется окно "Вопрос шаблона анкеты". При нажатии на кнопку [image] в поле "Вопрос" откроется выпадающий список с последними вопросами. Для того чтобы просмотреть весь список вопросов следует нажать на гиперссылку "Показать все".
    Для того чтобы ответ на вопрос анкеты был обязательным условием проведения документа, следует установить флажок "Обязательный" ( Рис. 5.61 ).
    Рис. 5.61. Документ "Возврат от дистрибьютора"
  • 6.
    При этом откроется окно справочника "Вопросы анкеты", в котором следует выбрать вопрос из списка уже имеющихся или создать новый вопрос анкеты (кнопка "Создать").
  • 7.
    После добавления вопросов следует нажать на кнопку "Записать" или "Записать и закрыть".